Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
When attempting to see topics that user's have posted in on their profile page the "next", "back", and number buttons point to incorrect URLS. For example, page two on TLM's page points here: https://www.cemetech.net/forum/search.php?search_id=509811212&start=50 when it should be https://www.cemetech.net/forum/search.php?search_author=TheLastMillennial&start=50

search_id should be search_author.
This also appears to affect the “Go to the new posts” page.

Well, maybe not the exact same issue, but something is wrong because it tells me no posts, unless I manually tack on the “start” parameter to the URL
I think the real question is, why are you going though my posfs? Razz
Interestingly enough, it's different every time.


Code:
https://www.cemetech.net/forum/search.php?search_id=695331309&start=50
https://www.cemetech.net/forum/search.php?search_id=2113100517&start=50
https://www.cemetech.net/forum/search.php?search_id=185689312&start=50
etc...


When you press back, refresh the page and click the same page number.
Oh no, looks like a search leak. If this keeps up, the Out Of Searches killer in the kernel may trigger and kill innocent searches somewhere in the world.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement