Hello. I'm having an issue running "make upgrade" inside the KnightOS folder I downloaded from the KnightOS GitHub page. When I run the command after entering the KnightOS-master directory, I get the following error:

Makefile:1: .knightos/variables.make: No such file or directory
Makefile:77: .knightos/sdk.make: No such file or directory
make: *** No rule to make target `.knightos/sdk.make'. Stop.

I'm on a Mac running macOS Ventura. Thanks for any help you can give.
What steps did you forget to do here: https://github.com/KnightOS/KnightOS#compiling
Thanks for posting this link. I followed the steps in the instructions, but even after installing libsdl2-dev via apt (a requirement for installing the KnightOS SDK), it is telling me to install it again. The message I'm getting is:

Please install SDL (and its headers), which is available through your package manager or http://www.libsdl.org/

The next thing I tried was installing SDL via the instructions on the SDL download page (link below), but I got the same problem.

I was also wondering if there is a way to directly download the 8xu files without having to compile them.

I'm now on a computer running Linux Mint 21.2, and any help would be greatly appreciated.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum