This is a MPEG2 player based on libmpeg2.
The source code can be found at
You can download the file here
The latest version is 1.031 which fixes a scaling bug that causes some pixels to be ignored.
Version 1.3 fixed an issue on real hardware where the screen would get corrupt. It is highly recommend that you run the latest version. Running 1.2 or older is a bad choice.
To use this program you will see a file browser
I have it set to show *.m2v files because there is no audio but it may play mpeg2 with audio (untested) but it will be ignored
As for what resolution you should make the video I would not go over half of screen resolution it should support 384x216 maximum but malloc errors are encountered
While the video is playing press exit to go back to the file browser if you want to do such.
In the readme I have included compiling instructions if you are interested in using libmpeg2 in one of your own projects.
To encode video I used
the following avisynth script

To encode the video I used HC encoder

There are some settings that you should be aware of please use 1:1 ratio for pixels
Also if you want height to be a multiple of 16 instead of 32 make sure progress sequence is checked (In settings 2)

Icon from
This is cool. First I tried to use a mpeg2 file (.mpg) and changed the file name to m2v and that displayed all distorted. After that I tried to convert to the m2v, but that displayed distorted too. I'm not quite sure how to get it to work correctly. Razz
Could you post a screenshot or take a picture of your calculator so that I can better understand the issue. If the resolution is not the same as the screen my program does apply scaling but the aspect ratio is preserved. On the plus side it sounds like the video at-least plays.
This is what it looks like on my calc:

When I exit sometimes it crashes my calc. Also, it won't let me get back to the main menu when I get back to the file browser from watching a vid.
Thank you for the picture. I did not encounter anything like that. Is it possible that you could send me the file and I will debug my software. As for exiting I too have had some issues with exiting. I think it has to do with ram being used that should not be used. It uses almost all 512kb starting at 0x08100000 Also 160kb is used starting at 0x880A2AD8 this is where SaveVRAM stores data. If there are some bytes in those regions that should be saved please tell me and I will fix it.
Here's the download link (sorry bout the rickroll Razz):
Thank you Spenceboy98, for helping me fix that bug. If anyone has any mpeg2 standard conforming files that break the player please post them here. The latest version is now in the archives.
It works pretty good. It still resets and doesn't let me quit after exiting the vid, but it works. It's also a little slow, but that's okay. Razz It runs the mpg file changed to m2v, and you can see whats happening in the video, but it looks a little corrupted.
Well to solve the speed problem you can encode the video with less frames per second. As to why sometimes the menu key does not work after stopping the video is unknown to me.
The menu key function may stop working because you are writing the menu allowance flag (and who knows what else) by using areas out of the stack and heap as RAM. Please do not complain about calculators dying after running add-ins which use such tricks...
I have updated my program. My update addresses crashing the calculator. Now it searches for the Save/load VRAM address and finds where it really is. The address is different depending on firmware versions. The download link is the same.
Another update. Theoretical support for the fx-CG-50. Please only download it from:

I also replaced the code that searches for the secondary VRAM buffer to simply use the getSecondaryVramAddress system call. This may make the program a bit more robust.

Untested as of now.
i get system error only
target = 00313a87
pc = 08100090

every time i start it
exit reboots the calculator completely
menu gets me back to the menu
I got the same issue in the emulator. It turns out it was failing in the startup script. I disabled LTO and now the error is gone. Please re-download using the Github link.
Thanks - the previous error is gone now.

File browser appears but folder file icons seem missing. I could see everything in root folder but going to casio folder for example gave system error W target 8c1e4947 and pc 00312f04 and @mainmem gave 0041e359 and same pc value as above.

when opening small m2v sample from root small progress icon spins in the top right corner for a couple of seconds - then frame changes from white to black and after this file browser is still visible inside as before but I could not browse as the keys become unresponsive.

I hope this helps - let me know if you wish me to do something else
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum