This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's Technology & Calculator Open Topic subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Calculator Tech Support => Technology & Calculator Open Topic
Author Message
lexdawg


Newbie


Joined: 15 Sep 2008
Posts: 2

Posted: 15 Sep 2008 01:21:48 am    Post subject:

My TI 89 died yesterday and I cant figure out why!!!! I've changed the batteries twice with brand new ones but its still totally unresponsive. The strange thing is that when I take a battery out and put it back in the calculator automatically turns on for a second but then dies again before I can hit any buttons.

Im really freaking out that my very expensive calculator that i bought less than a year ago is already dead for no reason. Please if you can think of anything I might be able to do or somewhere I could get it repaired I would much appreciate it. Good Idea
Back to top
luby
I want to go back to Philmont!!


Calc Guru


Joined: 23 Apr 2006
Posts: 1477

Posted: 15 Sep 2008 07:16:51 am    Post subject:

try holding 2nd, left and right when turning it on. Or plugging it into a computer.
Back to top
Ph34r_my_l33t_skillz


Advanced Member


Joined: 09 Oct 2007
Posts: 339

Posted: 15 Sep 2008 04:37:01 pm    Post subject:

The backup battery could be dead. I don't know if that would prevent it from turning on all the way, but It's possible. Try replacing the backup battery. If that doesn't work, try luby's suggestion or contact TI and ask them.

[Edit] I just thought, if you ran some program that could be a virus, it could be turning your calculator off whenever you turn it on. You may want to try taking the batteries out for about 24 hours (including the backup battery). Only do this if you ran a program that could be a virus, though.


Last edited by Guest on 15 Sep 2008 04:40:12 pm; edited 1 time in total
Back to top
lexdawg


Newbie


Joined: 15 Sep 2008
Posts: 2

Posted: 15 Sep 2008 06:49:47 pm    Post subject:

Hey thanks so much Luby... 2nd left and right worked!!! Its up and running again. Im not sure what happened... but Thanks a Million Guys ur life savers !!!!!!! :biggrin: :biggrin: :biggrin: :biggrin: :biggrin: :biggrin: :biggrin: :biggrin: :biggrin: :biggrin: :biggrin:
Back to top
Ph34r_my_l33t_skillz


Advanced Member


Joined: 09 Oct 2007
Posts: 339

Posted: 15 Sep 2008 07:41:58 pm    Post subject:

Glad it worked. Otherwise you'd have to delete everything, and that wouldn't be good. Smile
Back to top
benjamin22


Newbie


Joined: 06 Jun 2010
Posts: 1

Posted: 06 Jun 2010 06:47:41 pm    Post subject:

hey guys, ive just tried the 2nd, lef and right buttons.. and it doesnt works anyways.. what should i do??
i just bought it 8 months ago.. batteries are ok.

please help me!

im in middle of exams :S

thank you!

-ben
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
    »
» View previous topic :: View next topic  
Page 1 of 1 » All times are GMT - 5 Hours

 

Advertisement