I'm trying to set up a Minecraft server, which is dumb of me, but who cares? I have 1 GB of RAM and a 40 GB HDD on an ancient Windows Vista Basic computer, and relatively slow DSL. So how do I set it up? I have the .jar file that starts a minecraft server, accessable via LAN. The server will be version 1.5.2. My IP address (according to ipchicken.com) is So how do I do it? I started the .jar, and typed the IP into a client (user Spud did the same), but it didn't find the server.
Is your routers' firewall blocking any ports? If so, you'll need to open the port minecraft runs on.

For starters, launch the server and in your client type "localhost" as the server address and connect. If you connect, it's your firewall. If you don't it's the server.
Yes, it let me connect.
CalebHansberry wrote:
Yes, it let me connect.
You are on the inside of your firewall. The rest of the world is on the outside. You need to modify your router's configuration to port-forward the Minecraft port, as comic said.
Sad Rats. How in the world will I do that?
[Later]I think it is open (25565). I followed the directions on portforward.com, and yougetsignal.com tells me it is open. Any more ideas? Or is the port forwarding not as it should be? The results are the same: "Can't reach server", and if I try to connect then "Connection timed out: connect".
You'll need to login to your router from your web browser. Be careful, there's a lot you should learn before messing with your router, even more so with your firewall and port forwarding. Ask your parent for access to the router or, better yet, have them perform the changes. With that, port 25565 isn't the port you want. Yes, it's the default port minecraft wants to run on but going off of your line in SAX:
Hey, at least for the first time I got a sort of response from the server: " lost connection"

You'll want to open up port 47760 and forward it to the internal IP of the computer that is running the server. Now, chances are your entire network is setup with dynamic IPs. Meaning, one computer connects and gets assigned and another three connect and gets assigned through .0.8. If .0.7 and .0.5 disconnect, and a fifth device connects, the router will likely assign that device the .0.5 internal IP. And if you're pointing the MC server to .0.5 and all the sudden it's running on .0.7 because you shut off the computer and turned it back on a few hours later, the server won't be reachable until you forward the port to the proper IP again.

So, how do you fix it? You need to tell your router that a certain block of IPs are to be randomly assigned. For me, it's the 0.50 to 0.100 range. Then, I manually assign IPs to my devices based on their MAC address. When the computer connects to the router, it sends a MAC address. This address is unique, no other device has it. So, the router can easily block access based on a whitelist or a blacklist or it can assign a static IP (more advanced routers can even impose time restrictions for each MAC Address). Anyways, your static IPs should never be within the range of the dynamic IPs. Otherwise the router might randomly assign the IP specified for your server to your iPod or whathaveyou. So, keep your static IPs out of your dynamic IP range and you're in business!
Okay. I looked up port forwarding, and followed the instructions at portforward.com. I think I opened port 47760 correctly; here is what the router page says:

Start/End Port: 47760-47760
Protocol: TCP
LAN IP Address:
Start/End Port Remote: 0-65535
Remote IP Address:

And I followed the instructions found on the same site for setting the local IP to be static; here is what windows says in the Internet Protocol Version 4 (TCP/IPv4) Properties window:

Use the following IP address:
IP address:
Subnet mask:
Default gateway:

Use the following DNS server addresses:
Preferred DNS server:
Alternate DNS server:

So now, when I am connected to my network, where it normally says "Connected to the Internet", it says "". There is a globe shown on the taskbar, but I cannot view webpages. When I "Diagnose" with "Windows Network Diagnostics", it tells me the following:

Window tried a repair but a problem still exists.  Cannot communicate with Primary DNS Server(
Network diagnostics pinged the remote host but did not receive a response.

Upon running the Minecraft server, it said FAILED TO BIND TO PORT!. That was when the local ip ended in .9. It started normally after I changed it to .135. The client responds to localhost with Cant reach server. I have, at the moment, disabled the firewall, and the server is in offline mode.
You shouldn't be setting a static IP on your local computer; remove all that. You should be giving your computer a static DHCP'd IP on your router.
192.168.x.x is your internal IP. You can connect to other computers on your network with their internal address; welcome to the basis of intranet.

Now, back to the topic at hand: How did you login to your router?
Okay, stopped telling my computer what IP to use; now it says "Obtain an IP address automatically".

I login to my router by typing into the address bar in Firefox, and am greeted with:
Okay, good.

Start/End Port: 47760-47760
Protocol: TCP
LAN IP Address:
Start/End Port Remote: 0-65535
Remote IP Address:

That's okay. Now make sure the Minecraft server properties file lists 47760 and you should be good to go. If you encounter another error let us know.
Eh, Failed to bind to port again. The server.properties still says "" though (as usual, the one auto assigned was ending in .4). Should I type in my local IP or remove the IP from the file altogether?
Wat? You are telling your router to forward the port to .0.135 but the server thinks it's on .0.153? Fix it Smile
>.< I meant 135.

I removed the IP from the server.properties file. Currently neither localhost nor the IP ( detects the server. (meaning I tried localhost on the same PC and the IP on a different one.)
Okay. Is the console saying "Failed to bind to host" or the client? If it's the client, you need to specify the port in your URL. so x.x.x.x:47760 since the MC client just assumes the server is on the default port.

I'm not sure why the server would throw that but Google can tell you.
Well that isn't the error anymore, that was when the ip was specified, and as .135. Now the error is: "Can't reach server" in red letters at the "Play Multiplayer" screen. Upon trying to connect, the client on the server computer says "Connection refused: connect" but the other computer says "Connection timed out: connect".
Where is the "other computer" in relation to the server computer? (Inside or outside the network?)

Also, run through Portforward.com again and ensure Port 47760 is open.
It is on the same network, internet-bearing.

Do you mean an open port checker? Portforward.com only has one to download, which I'd prefer not to do; is it okay to use yougetsignal.com, which says it is closed?
[Edit] Perhaps it is closed because the router page still has the .135 number listed?
It's supposed to be listed. Listed as a Static IP outside of your dynamic range. Then the port (47760) needs to be forwarded to that IP (.135). I would assume the router would automatically open the port after that.

Perhaps try turning on or enabling uPNP or something of that nature.
Try removing the ip all together then make sure that port 25565 is open, then in the server.properties file, under the port setting type 25565, run the server, then type in your public ip into the ip box you get from editing a server in the server list of minecraft. If that doesn't work then you have something else configured wrong.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum