Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
So browsing Maxcoderz, I noticed that Ben Ryves finally finished a project similar to one of mine:

http://www.gamedev.net/community/forums/mod/journal/journal.asp?jn=273102

Hopefully he will share his PS/2 routines with the community, I'm sure I could have fun with that.
Laughing PS/2 routines for the calc have been out for a LONG time...
Not for the 83+, only for the silver. We couldn't get them optimized enough for the 6mhz proc.
You have your mouse driver compiled for the 83. If the 6MhZ processer can't handle it on an 83+, how is an 83 going to do anything? Please recompile it for the 83+(se) so I can write with it.
netham45 wrote:
You have your mouse driver compiled for the 83. If the 6MhZ processer can't handle it on an 83+, how is an 83 going to do anything? Please recompile it for the 83+(se) so I can write with it.
The 6MHz 83 and 83+ can handle it fine... Ben's emerson routines work on it. I will have to reconfigure for use with DCS though, which I will do as soon as I get DCS in a useable state.
I didn't get the emerson keyboard stuff to work. It set autorepeat to high. I couldn't configure it.
netham45 wrote:
I didn't get the emerson keyboard stuff to work. It set autorepeat to high. I couldn't configure it.
Hmm, really? You couldn't type at all; no letters appeared?
Uh..... It was a program to let me control a sprite. I couldn't set which keys to set as sprite controls because repeat was too high. There were no letters in Emerson.

Edit:I know what you are talking about now. I could ge tthe one that let me type to work, but emerson's didn't work.
Ah, gotcha. I'll have to research that a bit more then.
Maby the program was optimized for the 83+..... Maby I should try it on my 83+. I only tried it on my 84PSE.....
Ohhh, that's why. The SE completely screws up the timing for it.
what? I wasn't using a SE. I was executing a program called kbd2 from homescreen...
SE as in Silver Edition, not Shell Extension. The SE runs at 15 MHz, while the BE (Black Edition), aka a regular TI-83+, runs at 6MHz. The 2.5x speed makes the mouse unable to keep up with the PS/2 protocol transfer.
KermMartian wrote:
SE as in Silver Edition, not Shell Extension. The SE runs at 15 MHz, while the BE (Black Edition), aka a regular TI-83+, runs at 6MHz. The 2.5x speed makes the mouse unable to keep up with the PS/2 protocol transfer.


Ah..... I was using the keyboard btw. there was an emerson program that let you specify keys to move the sprite with. The mouse worked great.\

Edit:As soon as I find my link cable I will try it on my 83.....
OK, let me know how that goes. I have tentative permission from Ben to use the emerson routines as long as I give him credit, so I'll probably use them as the basis for the SE.
I have the same problems while using the keyboard on my 83+ =|
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement