I am a Mac user, and I have had a lot of problems with trying to get the CE C compiler to work. The first time I tried, I had to reupload Xcode in order for zsh to recognize the make command, and then the path wasn't working, but then, when I finally got it to work, it always ends with an error: not enough memory to complete the assembly, but I have no idea what this actually means, or how to fix it. I tried it on my friend's Mac, and had the same error. Does anyone know what's wrong?
The latest (as of this post's date) release of the toolchain comes with a version of fasmg that didn't yet have the memory allocation "fix" that is necessary for recent versions of macOS.

It's been fixed since by fasmg's author, and it will be part of the upcoming toolchain release, but in the meantime you can download one I've built here: https://usercontent.irccloud-cdn.com/file/KtN7sflJ/fasmg.zip
Extract the fasmg binary from that zip inside your CEdev/bin/ folder (replace the old one).

Then it should work...
Thanks! I'll tell you if it works when I get home this afternoon.
Thank you, it totally works now!
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum