Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
If there are any issues with the server, please let us know here. We can't promise to get every message sent over chat nor should we rely on messengers. By posting on the forums we'll have a record to refer back to.


I'll start! The Abba world has been the same map for the last 3 or 4 refreshes. Could we have an admin take a look at the script to see if this is a coincidence or an error?
Because of an incompatibility between TerrainControl and Minecraft 1.12, I had to switch back to the Normal generator. However, our AbbaRegen plugin only allows you to specify the precise generator (it defaults to TerrainControl) if you also specify the exact seed first. Therefore, our abba regeneration code currently uses the same seed every time, hence why it's a fresh copy of the same world. I'll go in and make a temporary fix for that. From the lack of attention paid to the following issues, I'm getting a little worried about 1.12 support in TerrainControl, and might have to assign either Lennart or myself to it:

https://github.com/MCTCP/TerrainControl/issues/535
https://github.com/MCTCP/TerrainControl/issues/537
Furnaces burn one less fuel than they should. 1 coal should burn exactly 8 items, but it burns 7.95 instead. 2 coal smelts 15.95 items, and 8 coal smelts 63.95
This might be caused by the fuel counter and item smelt time counter being checked in the wrong order, as it is always exactly one tick short, regardless of the amount of fuel in the furnace.
commandblockguy wrote:
Furnaces burn one less fuel than they should. 1 coal should burn exactly 8 items, but it burns 7.95 instead. 2 coal smelts 15.95 items, and 8 coal smelts 63.95
This might be caused by the fuel counter and item smelt time counter being checked in the wrong order, as it is always exactly one tick short, regardless of the amount of fuel in the furnace.


Rolling Eyes This is most likely a Spigot issue and would be more appropriate in their respective bug tracker.
Falling blocks (sand, gravel, dragon eggs, anvils, concrete powder) can be duplicated by dropping them into the exit end portal. This has to do with the spawn protection. In vanilla, something similar (but a different bug) can be done, but it involves breaking end portal bedrock and using slime blocks and pistons to send the blocks through the portal while simultaneously pulling them back into the mechanism with slime. Here, this probably has to do with the falling block's behavior of placing a block and the spawn refusing to let a block get placed (dropping the block as an item) while not registering the falling block place event, causing the entity to drop as an item as well.
Alex wrote:
commandblockguy wrote:
Furnaces burn one less fuel than they should. 1 coal should burn exactly 8 items, but it burns 7.95 instead. 2 coal smelts 15.95 items, and 8 coal smelts 63.95
This might be caused by the fuel counter and item smelt time counter being checked in the wrong order, as it is always exactly one tick short, regardless of the amount of fuel in the furnace.


Rolling Eyes This is most likely a Spigot issue and would be more appropriate in their respective bug tracker.
That's what I was thinking, too. Please post it in their issue tracker if you're able, commandblockguy, and let us know what they say.

Regarding the dupe bug: I have put in what should be a permanent solution for that that still allows the dragon to be properly spawned.
Fireballs from Ghasts and Blazes do no damage to either the player or the environment (besides Blazes catching blocks on fire). This means that Ghasts are totally harmless except for the insanity-inducing noises, and Blazes can be cheesed by placing pressure plates on the ground, at which point they are basically Zombies with Slowness and Levitation.
I can see why the fireballs do not damage terrain, but the no player damage thing seems like a bug.
Umm, I really don't want to be explodified by a Ghast, so perhaps we forget about the bug, and let it exist in peace!

I think that ghasts shouldn't be able to break blocks, but they should be able to hurt the player, and blazes should be able to set the player on fire.

Just fix the bug (somehow) and disable mobGriefing in the nether (IIRC you can do that)
Ghasts breaking blocks is part of their attack, if I recall correctly, but I don't think they can break nether rack.

Has the no-damage stuff been this way since 1.12 or longer than that? Like, is there a rough idea of when this started occurring?
It has been like this since I joined the server in 1.11.

Also, unless you have some saturation , when entering the End your hunger is set to a different value.
commandblockguy wrote:
Also, unless you have some saturation , when entering the End your hunger is set to a different value.


I believe that may be a spigot bug.
I did some testing on my testing server; the coal thing isn't a CraftBukkit's fault, so it's probably a plugin.
commandblockguy wrote:
I did some testing on my testing server; the coal thing isn't a CraftBukkit's fault, so it's probably a plugin.


I hate to be that guy but this seems like a pretty small issue. I don't have the time nor the desire to track down where the bug is coming from. If it was something like 1 coal burned 5 items instead of 8, that would be something we'd want to track down. But 7.95 instead of 8?

As a contradiction, I sort of understand. It might as well be 7 instead of 7.95 but at the same time this doesn't seem to be a big enough issue across the constituents to warrant further investigation. But I do appreciate you taking the time to track it down, so that if it becomes a larger issue we know where to start.

Can you maybe lay out how you tested? Is it just as simple as putting 8 ores in a furnace with 1 coal and seeing how much it burns through? If I ever find myself with some free time to go through the plugins on an offline version of the server I'd love to follow the steps and find the culprit.
I just threw down a furnace in both servers and a singleplayer world and put in one coal and 8 ore, and in my testing server and in Vanilla singleplayer it smelted 8; on Cemetech it smelted 7.95.
I noticed the problem months ago. I'm not sure when it started, but it was definitely there in 1.11.1---the problem is much more noticeable when smelting iron stuff into iron nuggets. It didn't bother me enough to say anything. I thought it was just a minor multiplayer bug.
commandblockguy wrote:
I just threw down a furnace in both servers and a singleplayer world and put in one coal and 8 ore, and in my testing server and in Vanilla singleplayer it smelted 8; on Cemetech it smelted 7.95.


Simple enough. I'll find some time to test with each plugin. As DrDnar pointed out it has happened since 1.11 so I don't need to take the time to update my local server. Maybe I'll get to this sooner rather than later. Here's hoping it's just one plugin and not a combination of them, haha. I'll spend some time thinking about what plugins could cause this and work from there.
There's also the point that it might miss game ticks if enough people are on when you are trying to test, as well. Did you test this when no one else was online?
A skipped game tick shouldn't affect the operation of furnaces. The check if the item is finished smelting, the check if the fuel is used up, and the incrementation of those counters should either all happen or none happen at all.
(should this topic be pinned / stickied?)

Beds don't work.
I think this is a config option in EssentialsSpawn.
Normally this isn't an issue, because you can just /home back to wherever you would put a bed, but it causes issues with replaymod if you respawn at spawn before teleporting back.
[quote="commandblockguy"]Beds don't work.[quote]

How are they not working? Can you not sleep in them?

Quote:
Normally this isn't an issue


Quote:
but it causes issues with replaymod if you respawn at spawn before teleporting back.


Sounds like beds don't work because you don't spawn at your bed upon death? I'm not convinced that's on us to fix as our sever has always sent players to server spawn - not their home point - upon death. This doesn't sound like a server bug, rather a bug with Replaymod. We don't allow client-side mods but we have allowed Replaymod on a case by case basis but it doesn't mean we're obligated to make sure it works.

You guys have used Replaymod before, right?
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement