ave made an account just to ask you about this. I am the *only* calc programmer at my school, and have been showing DoorsCS7.2 beta 3 off to my classmates as a Windows-like interface. (Windows and Doors, see the connection) Well someone asked me, can you get on the internet, so I looked it up and here it is, Gossamer. I've got my TI-84+SE connected to the computer with a DirectUSB cable, installed the filter driver, and started up Gossamer on the calc. Then I go to the console (Win7 64b), and type: 

"gCnClient -n WebHub -l NoahClient -d d" 

with Gossamer already started. Gossamer stays on the "Loading page..." and the console looks like this: 

"Info: Using defoult server host gcnhub.cemetech.net" 
"Info: Using defoult port 4295" 
"Direct USB connection created successfully." 
"Resolved hostname." 
"Wrote 21 bytes to socket (join msg)" 
"Direct USB device may have stopped responding..." 
"Direct USB deviece still connected" 

Gossamer never exits the "Loading page...", and no more bytes or frames are written to anything. I think this is a calc problem, and I would LOVE to show it off to my friends, but I need some help fixing this 

*edit: I started the client while the calc was plugged in and at the homescreen, the client connected to DirectUSB, wrote 21 bytes(join msg) to the socket, then I started Gossamer, the client sent a frame of length 40 to sever, then wrote 58 bytes(frame msg) to socket, then: 

"Direct USB device may have stopped responding..." 
"Direct USB deviece still connected" 

So it looks like the server is having some problems, like its not responding to my sent packets. I'll check my firewalls and come back.

*edit2: I have tested chat and it seems like the gCn server is down....
It seems like we may have resolved this, but it boiled down to two issues:
1) The gCnWeb bridge had not launched successfully due to Sonicrule's new SSL additions. I disabled SSL in the gCnWeb bridge and was able to launch it.
2) You were mis-spelling "WebHub" as "WEBHub". The hub names are case-sensitive.

By the way, I also noticed that you mentioned that SAX and IRCHub are not connected when you were on your way out. In fact, SAX and IRCHub are connected, so you can chat on SAX (which is also #cemetech on Efnet) from your calculator using CALCnet Chat!. However, you were using IrcHub instead of IRCHub. Smile
I have to say, you are the best Admin of any site I've been to. But for the Gossamer thing.

- Case sensitive. Gosh. Okay, I think I've got it.
- Interesting to note on the SSL. So there was an issue after all.
- So SAX and CalcChat ARE connected. I will test that in the morning.

Thanks for all you do. You probably don't get paid enough for this.
You're very kind to say so, sir, thank you. This is all volunteer work, from my programming to maintaining Cemetech, so it's nice to have it be appreciated. Feel free to post further if you run into additional problems or you have more questions about gCn and CALCnet.
okay well i'm kind of having a similar issue, NoahK told me id better post it here, i install the lib thing, run gossamer, then in cmd, enter in gcnclient.exe -n WebHub -l Womp -d d
and i get
info: using default server host gcnhub.cemetech.net
info: using default port 4295
but nothing on the calculator...
Try starting gCnClient with the calc plugged in at the Doors app, then once rose two lines show, start Gossamer.
calculator just freezes...
*edit tried it again and it does the same thing as before... gives me the two lines and nothing on calc
The cable you are using....does it work with ti connect on a different usb port?
yeah, same cable i always use...
Unplug the calc, click on install-filter-windows, remove the all filters, restart your computer, plug the calc back in, in tall the filter on to it again, and try gCnClient then.
Did you install the filter driver on the USB port the calculator uses, with the calculator plugged into that port and turned on? That's key.

Edit: Can you post exactly the steps you're using, what isn't working about them, and what you tried to do to fix it?
yes yes
of course i can Smile
I plug in my ti-84 + and have doors opened on it
I click on the install-filter-win and install it on the Ti-Handheld device thing
I open up CMD and cd to the folder where all the gcn stuff is
I type in
gncclient.exe -n WebHub -l Womp -d d
then tap on enter.
I then go click on the gossamer program on the calc
CMD returns
info: using default server host gcnhub.cemetech.net
info: using default port 4295
and on the calculator it just says loading page
Try starting the gCnClient when the calculator is at the homescreen instead of in Doors CS. You should see something about the calculator being connected in the command window.
i don't know if this helps, but when i start the gCnClient then go to click on gossamer, everything just freezes and it unfreezes when i unplug the calc... and it doesnt give me anything about being connected...
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum