Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
How many programs do you have? And do you also have MirageOS? (perhaps that would explain the alphabetical sorting).

Edit: aha! It seems that folders cause that name-alignment bug. Easily fixed.
I have 119 programs, and I do use MOS to sort my progs, because otherwise I wouldn't be able to find anything.
Gooood, goooood. I fixed the name alignment issue from folders; it was an oversight by me from when I realigned the desktop icons. Folders are handled in a different section, so I forgot to update the increment and limit check there. Now for this scroll bug; first I need to find a way to replicate it.
Ok, Got it to load on ROM 1.12. I noticed that you need to delete the appvar everytime you update DCS, you might want to include that in the readme.

I think you also need clear the graph buffer when you have it run a program, if you want an example, http://calcgames.org/cgi-bin/files/files.cgi?ID=1195 and run the prgm TETRISJD and you will see what I mean.

Also, not so much a bug, but on PTI, I noticed that the batt meter does not seem to be "live", because I adjusted the contrast inside DCS, and the batt meter stayed the same. I exited and restarted, and the batt meter was where it should have been.
calc84maniac wrote:
(Taken from Doors CS 5.7 Beta 1)
calc84maniac wrote:
Okay, I have (almost) the same problem as foamy3. It only shows the names of the progs in the top row. When I scroll down it is still in the As, but when I scroll up it is in the B's and I can't scroll up any more.

Update: I deleted my one folder and it now displays right, but when I scroll down then up, it is suddenly in he M's (instead of the B's), and when I scroll down and up again, it is in the E's. (Another scroll bug perhaps?)


The bug was slightly different for me. When I had 4-6 programs/folders, the bottom row didn't have names. Also, the strangest thing, there was a random lowercase letter to the far right of the screen on the top row. When I got a seventh program, I scrolled down, then back up, and the screen went blank. I was forced to pull a battery.

EDIT: TI-84+SE 2.21
foamy3 wrote:
EDIT: TI-84+SE 2.21


You do know that 2.41 is out and you shoud at least update to 2.30. But if you do, do not use a directlink cable. Those cause major errors in updating.
netham45 wrote:
foamy3 wrote:
EDIT: TI-84+SE 2.21


You do know that 2.41 is out and you shoud at least update to 2.30. But if you do, do not use a directlink cable. Those cause major errors in updating.


1, I don't trust those calc-lock bastu....uh... jerks, and 2, I only have a silverlink cable. Silver is the same as direct, right?
Silever is not a directlink. A directlink is a cable that plugs into the USB port and 2.30 doesn't have the lock mode(right?).
netham45 wrote:
Silever is not a directlink. A directlink is a cable that plugs into the USB port and 2.30 doesn't have the lock mode(right?).


Mine plugs into the USB port. And where can I get an old OS?
Direct USB doesn't cause any problems updating the OS.....
@elf I have tried updating the OS on my 84 4 times w/ a directlink and each time it has crashed and I had to use my silverlink to finish it.

@foamy The Directlink plugs into the USB port on the computer like the silver link, but the directlink plugs into the USB port on the calculator too. The Silverlink connects into the IO port.
Oh, I figured since it came with a Silver Edition calc it was a silver link. I guess it's a direct link.
Oh, and you can find 2.30 at http://www.fayar.net/east/teacher.web/Math/young/DwD/Workshops/TI/TI84Plus_OS.zip
What advantages does it have over 2.21? Just more error checking?
foamy3 wrote:
calc84maniac wrote:
(Taken from Doors CS 5.7 Beta 1)
calc84maniac wrote:
Okay, I have (almost) the same problem as foamy3. It only shows the names of the progs in the top row. When I scroll down it is still in the As, but when I scroll up it is in the B's and I can't scroll up any more.

Update: I deleted my one folder and it now displays right, but when I scroll down then up, it is suddenly in he M's (instead of the B's), and when I scroll down and up again, it is in the E's. (Another scroll bug perhaps?)


The bug was slightly different for me. When I had 4-6 programs/folders, the bottom row didn't have names. Also, the strangest thing, there was a random lowercase letter to the far right of the screen on the top row. When I got a seventh program, I scrolled down, then back up, and the screen went blank. I was forced to pull a battery.

EDIT: TI-84+SE 2.21
Nope, you have both bugs there. You have both the name misalignment bug and the scroll bug.
I just got a bug. I was playing Gemini (MOS version) in DCS 5.7 beta 2 and pressed clear during gameplay to quit. It went to the DCS BASIC execution error (yes, BASIC error in an ASM game). The DCS screen then just showed a folder named 'M' with a little padlock picture in the top left corner. All of my programs were in the folder. DCS didn't re-archive Gemini, but that's understandable because of the execution error.

EDIT: When I quit the shell and reloaded it, the folder was gone and everything was normal. I tried to run Gemini again, and when I hit clear my screen just went blank. It appears to be turned on still. I tried 2nd up to darken contrast, but nothing happened.
foamy3 wrote:
I just got a bug. I was playing Gemini (MOS version) in DCS 5.7 beta 2 and pressed clear during gameplay to quit. It went to the DCS BASIC execution error (yes, BASIC error in an ASM game). The DCS screen then just showed a folder named 'M' with a little padlock picture in the top left corner. All of my programs were in the folder. DCS didn't re-archive Gemini, but that's understandable because of the execution error.

EDIT: When I quit the shell and reloaded it, the folder was gone and everything was normal. I tried to run Gemini again, and when I hit clear my screen just went blank. It appears to be turned on still. I tried 2<sup>nd</sup> up to darken contrast, but nothing happened.


oh yeah, I recently got a TI-OS ERR:Memory when trying to run a big Asm program which quit to the home screen...
Argh, I forgot to turn on the error hook for ASM programs. Easily fixed.
i cant dl the beta..need help...
ooh, my mistake. I can fix that.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 2 of 2
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement