This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's Technology & Calculator Open Topic subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Calculator Tech Support => Technology & Calculator Open Topic
Author Message


Joined: 28 Apr 2010
Posts: 2

Posted: 28 Apr 2010 11:44:50 am    Post subject:

My daughter's TI-84 Plus silver turns on but no other key works. Cannot turn it off because 2nd key doesn't work. Only a black square blinks on the screen.

Computer can still connect to it via USB and can read device info. Tried loading OS 2.43, after the download, the calculator and os downloader promptly shut off after displaying "Verifying ...", with no confirmation of success or failure. When turned on, it would display OS 2.43 and "RAM cleared" though, so it looks like the OS is loaded.

Tried replacing all AAA batteries; tried removing all batteries for more than 5 min; tried blowing compressed air into the I/O port; tried sucking the I/O port with a vacuum ball; all to no avail. [DEL] and [CLEAR] keys don't work so cannot perform the steps in "In Case of Difficulty" topic.

Opened up the calculator, but don't see anything wrong.
Back to top

Active Member

Joined: 29 Aug 2008
Posts: 565

Posted: 29 Apr 2010 07:42:52 am    Post subject:

A friend had the same issue with the keyboard. The calculator turned on but gave no response to key presses. It was a TI 84+ SE, too.

You should try go to the store and request a exchange for a new calculator. My friends' calculator was exchanged by a Texas Instrument staff.
I think it is a hardware problem from factory.

Meanwhile one temporary fix we discovered is pressing all keyboard during sometime and the calculator suddenly respond to keys. But this lasts some hours or days until the same error happens. You should show in the store the calculator with the keys not working.

I hope this helps. I tried to be clear but English is not my first language. Any doubt feel free to ask.

Last edited by Guest on 29 Apr 2010 07:45:12 am; edited 1 time in total
Back to top


Joined: 28 Apr 2010
Posts: 2

Posted: 29 Apr 2010 12:01:15 pm    Post subject:

Thanks Galandros. Your English is perfectly fine; it's very clear.

Unfortunately, the calculator is over one year old, so I cannot take it back to the store, and it's out of TI's warranty as well.

I already bought a new calculator for my daughter, because her school work can't wait. I was just wondering if I can salvage it.
Back to top

Advanced Newbie

Joined: 07 Aug 2009
Posts: 56

Posted: 12 May 2010 07:52:26 pm    Post subject:

i've heard of people buying semi-dead calcs on ebay just because they want the parts, since the proccessor, memory, screen, etc. seem to still be intact.
Back to top

Advanced Member

Joined: 12 Jan 2007
Posts: 455

Posted: 13 May 2010 03:51:33 pm    Post subject:

I would be interested in it. I take semi-dead calculators off people's hands, particularly ones that work perfectly fine and can execute the OS without problems (such as yours) but is useless to most people (since the physical keys don't work).
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» View previous topic :: View next topic  
Page 1 of 1 » All times are UTC - 5 Hours