Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's z80 & ez80 Assembly subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Z80 & 68k Assembly => z80 & ez80 Assembly
Author Message
Authentic INTJ

Super Elite (Last Title)

Joined: 25 Nov 2004
Posts: 3976

Posted: 02 May 2006 01:55:55 pm    Post subject:

I'd have to make a lot of assumptions to say this, but: [font="courier new"]Asm(prgmname
Back to top


Joined: 30 Mar 2006
Posts: 208

Posted: 02 May 2006 01:59:14 pm    Post subject:

If you got a syntax error, you probably didn't put Asm( before the program name. You can find this by pressing [2nd][CATALOG], then scrolling down. It should look like this:


Sorry, Weregoose. I started typing before you posted.

Last edited by Guest on 02 May 2006 02:00:39 pm; edited 1 time in total
Back to top


Joined: 02 May 2006
Posts: 2

Posted: 02 May 2006 02:30:57 pm    Post subject:

THANK YOU! I did indeed forget to put Asm( before the program name... and it does work perfectly. Wow, something so simple...lol. I guess I really am a newbie. Neutral
Back to top
The Dragon Master


Joined: 26 Jul 2005
Posts: 188

Posted: 08 May 2006 04:14:24 pm    Post subject:

Simple soultions, simple soultions... I thought you knew that....
Back to top


Joined: 13 Aug 2006
Posts: 1

Posted: 15 Aug 2006 10:14:54 am    Post subject:

I tried the fakerest.8xp on my Ti-84+ (OS v2.41) and it doesn't work. Can anyone help to modify the MEMRESET.8xp programme so that it shows "TI-84" instead of "TI-83". Then everything should work fine for me.
Back to top
The XORcist!

Advanced Member

Joined: 20 May 2003
Posts: 268

Posted: 15 Aug 2006 01:02:42 pm    Post subject:

ti_noob wrote:
I tried the fakerest.8xp on my Ti-84+ (OS v2.41) and it doesn't work. Can anyone help to modify the MEMRESET.8xp programme so that it shows "TI-84" instead of "TI-83". Then everything should work fine for me.

Hi and welcome to United TI, ti_noob Smile
You made a good suggestion here, and I thinks it's for me to start the assembler again. In other words, I will update Fake Reset to suit the 84+(SE) models. Expect the new version finished in two weeks. I'll tell y'all when it's ready!
Cheers Rolling Eyes

Last edited by Guest on 15 Aug 2006 01:04:46 pm; edited 1 time in total
Back to top
The Dragon Master


Joined: 26 Jul 2005
Posts: 188

Posted: 15 Aug 2006 10:03:57 pm    Post subject:

I made one that shows your real calc hardware version.
Back to top


Joined: 09 Dec 2006
Posts: 10

Posted: 09 Dec 2006 09:43:35 am    Post subject:

First of all: Hi! I'm new here..

I just started learning ASM, though, I'm in the exam period.
Less than a week ago I found the ZClear ASM prog. (First FakeClear)
Because I have a TI-84 Plus, I needed to find a way of editing the message on the screen (TI-83..) So I just used a program that can lock/unlock programs and I unlocked ZCLEAR..
I looked trough the code and found what I was looking for..
I changed "TI!83" to "TI!84" and somewhat after that the "1" to "2" and the "12" to "41"
Now the screen showed the right text in function of my TI-84..
But, I hated the menu at the begining, so I looked over the internet but could find something better.. till today !!!
After some days looking throug sites, forums, I finnaly found a new version..
But it still doesn't work right on the 84.. Or is there somewhere..?

I just want to say, thank you and nice work :D

Btw: Sorry that I bring up this old thread Sad
Back to top


Joined: 09 Dec 2006
Posts: 10

Posted: 10 Dec 2006 01:49:52 pm    Post subject:

Yeah, I know.. first I bump a topic, and then I dubbelpost in the same topic !!
But I realy need help!
I know some basic ASM and I wanted to add 'support' for my TI-84+ to this program..
Now, I just changed the '.asm' (of the source) to '.z80' and started editing.
Well.. first I compiled it without any changes.. 70 errors !
Than I changed (what I tought that was the problem) the labels..
I edited some.. compiled.. 50 errors!
Ok.. so on.. now I'm on 17 errors and I don't know what to do..
I'll add my 'source' below and the errors..
Maybe someone can help me..

BTW: I just need to change the Calc-Version..
Everything works on my TI-84+, only it displays: 'TI-83 Plus Silver Version' instead of 'TI-84 Plus'
The OS version is ok!!

Please help me!

I just don't have the CALL (_homeup), so.. :S

Ok, I'm on 11 errors.. the _homeup errors are gone ! (Changed '_homeup' to '4558h')

Still 8 errors to go...

0 errors !!! TESTING TIME !

Edit5 (FIVE!! Razz):
It works! I only have to change some things.. It displays 'TI-84 Plus 000000000 ^'
So.. that has to be fixt!
And.. this DOESN'T work on a TI-83.. this is only for the TI-84+
(This is because I only changed the text..)


*Removed Attachement*
You can find the download here

Last edited by Guest on 11 Dec 2006 07:05:23 am; edited 1 time in total
Back to top

Advanced Member

Joined: 19 May 2004
Posts: 399

Posted: 18 Dec 2006 12:17:28 am    Post subject:

I'm sorry all, I guess that's what happens when you're out of town for too long...

I had actually written an 84p/84pSE including version about half a year ago, with the help of littleboystein - he was so kind to test the prog for me, seing as I only have a 83pSE

I won't upload it to the forum, seing as JaMeSsS got there first, and he deserves credit for his version of the prog! had I wanted the spot, I should just have been more up front with my version, well well, that's how things go...

for anyone still wanting to try my version, it is available from here

sorry for being so slow on the release...

this one should:
detect and display correct calc version (83p/SE/84p/SE)
detect and display correct os version (1.12-x.xx)
reset contrast correctly
display everything in correct place and size


Last edited by Guest on 18 Dec 2006 01:13:40 am; edited 1 time in total
Back to top


Joined: 21 Dec 2007
Posts: 1

Posted: 23 Dec 2007 10:42:49 am    Post subject:

NETWizz wrote:
I am already on it.

I can fix it so it says 1.14, but I cannot do much else to it without the source.

hey i want a fake clear memory to ti 89 as quickly as possible please.thanks in advance
Back to top

Active Member

Joined: 11 Apr 2007
Posts: 544

Posted: 23 Dec 2007 12:09:50 pm    Post subject:

Try searching TICalc.org... You might come up with more than you will get here.

Couldn't find any for the 89...

Last edited by Guest on 23 Dec 2007 12:13:44 pm; edited 1 time in total
Back to top


Joined: 17 Nov 2011
Posts: 1

Posted: 19 Nov 2011 06:41:36 am    Post subject:

Hello, Sorry I'm new here, but why I can't download the files?
If I tr to download there comes this message: [#10171] You do not have permission to view this attachment.

Can anybody upload a FakeReset on Rapidsharen, Uploaded.to or something like that?

Sorry for my bad English!
Greetings from Germany Smile
Back to top

Active Member

Joined: 19 May 2009
Posts: 520

Posted: 19 Nov 2011 10:43:00 am    Post subject:

Now that you are registered, does it work?

Last edited by Guest on 19 Nov 2011 03:53:42 pm; edited 1 time in total
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
    » Goto page Previous  1, 2, 3, 4
» View previous topic :: View next topic  
Page 4 of 4 » All times are GMT - 5 Hours