Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's z80 & ez80 Assembly subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Z80 & 68k Assembly => z80 & ez80 Assembly
Author Message
puromtec


Newbie


Joined: 15 Mar 2011
Posts: 6

Posted: 19 Mar 2011 09:12:46 am    Post subject:

I need the asm version of the basic commands:
Send({222,500})
and
Get X

My robot device works if i use the basic commands on it. I have an asm app that needs to communicate to it the very same way.

I have read and tried the routine example from the TI 83 plus system routines document. I am building a real list using L1 and sending it. My calculator is a TI-84 plus. Attached is the code. I am using brass/latenite. My macros cause the app to pause and wait for user to hit enter. It fails on the SendVarCmd, obviously.

Thanks in advance for your help.
Back to top
Sven.Thomas0


Active Member


Joined: 19 May 2009
Posts: 520

Posted: 20 Mar 2011 11:41:18 am    Post subject:

Sorry, I've never worked with anything like this Very Happy Also, in case yo want to work with archived data in the future, B is 0 if the var is in RAM, otherwise it is whatever the flash page the var data is found on. However, you did have the technique of using or a correctly ^-^ (I like that trick Smile)
Back to top
puromtec


Newbie


Joined: 15 Mar 2011
Posts: 6

Posted: 20 Mar 2011 06:42:42 pm    Post subject:

Thanks anyways... It just boggles the mind that my code does not work. I've sent a message to ti-cares@ti.org with the very same question. I've got a rather large app (for a beginner I guess) that employs its own user controls (command list, select list and text editor) and a database like variable to maintain the state of the application. If anyone can give me the tip i need, I'll certainly give you credit in the app itself.
Back to top
Sven.Thomas0


Active Member


Joined: 19 May 2009
Posts: 520

Posted: 20 Mar 2011 07:32:11 pm    Post subject:

If I knew the protocol for the device you are sending the data through, then I might be able to come up with something. Are you using USB or serial? I will see if I can figure out what exactly goes on with the Send( command :)

EDIT: Here is the best I could come up with. I have no idea if it will work or even if my mnemonics are correct Very Happy:

Code:

SendL1:
 bcall(_zeroOP1)                  ;EFC541
 ld a,5Dh                         ;3E5D
 ld (OP1+1),a                     ;327984
 bcall(_CheckFindSym)             ;EFF142
 jr c,SendFailed                  ;380A
 ld a,b                           ;78
 or a                             ;B7
 jr nz,SendFailed                 ;2006
 bcall (_SendVarCmd)              ;EF****
 bit comFailed,(IY+getSendFlg)    ;CB**
 ret z                            ;C8
SendFailed:
;Put code here for if the send failed?
 ret                              ;C9

GetX:
 ld a,8                           ;3E08
 ld (8A0Bh),a                     ;320B8A     This is a flag...
 bcall(_zeroOP1)                  ;EFC541
 ld a,58h                         ;3E58
 ld (OP1+1),a                     ;327984
 bcall(4A11h)                     ;EF114A     GetVarCmd
 ret                              ;C9


Last edited by Guest on 20 Mar 2011 07:59:01 pm; edited 1 time in total
Back to top
puromtec


Newbie


Joined: 15 Mar 2011
Posts: 6

Posted: 21 Mar 2011 09:12:01 am    Post subject:

I appreciate the help. I'll look further into this later today.
Back to top
Sven.Thomas0


Active Member


Joined: 19 May 2009
Posts: 520

Posted: 21 Mar 2011 08:28:43 pm    Post subject:

I've never worked with bots or linking before, so I am really making a stab in the dark. Hopefully it works though! I'm not very confident at all about that, though.
Back to top
puromtec


Newbie


Joined: 15 Mar 2011
Posts: 6

Posted: 22 Mar 2011 12:07:14 pm    Post subject:

That's alright. I've gotten a response from ti-cares@ti.org. Although, the person responding thinks I cannot find the program "Send(" buttons. I've sent back with a request that he escalate to someone more technical (in a nice way).
Back to top
tifreak8x


Elite


Joined: 27 Aug 2005
Posts: 956

Posted: 23 Mar 2011 06:48:47 am    Post subject:

Might I suggest you jump over to http://cemetech.net and attempt to get the attentions of one BrandonW? He is a wiz where such things are concerned, and will probably be able to give you a bit of help or point you in the correct direction. KermMartian is also knowledgeable with asm as well, not sure if he will have this particular bit of knowledge though. Wouldn't hurt to ask.

And no, not trying to pull users from here, just trying to help the user find someone that might have more information Razz
Back to top
puromtec


Newbie


Joined: 15 Mar 2011
Posts: 6

Posted: 23 Mar 2011 10:08:23 am    Post subject:

Thanks, certainly will.
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
    »
» View previous topic :: View next topic  
Page 1 of 1 » All times are GMT - 5 Hours

 

Advertisement