This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's Technology & Calculator Open Topic subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Calculator Tech Support => Technology & Calculator Open Topic
Author Message
mrmprog


Newbie


Joined: 04 Feb 2011
Posts: 44

Posted: 16 Feb 2011 09:39:39 pm    Post subject:

I got a broken 83+. When I first got it, the screen was all mixed up, so I linked it to my 84 and sent lcdfix. That did not do anything. After that, I did the self test, reset all mem, and cleared ram. That did not work. Then I let it sit for weeks without any batteries. Now, when I turn it on, I get a black screen. My 84 can send stuff to it fine, the screen just does not work. Any help?
Back to top
Xeda112358


Active Member


Joined: 19 May 2009
Posts: 520

Posted: 16 Feb 2011 10:08:14 pm    Post subject:

Ooh, wow that is tough. It definitely sounds like a hardware problem (to me) and I have never had to replace or fix a screen. I cannot help you there, sorry.
Back to top
Impiety


Newbie


Joined: 06 Feb 2011
Posts: 5

Posted: 16 Feb 2011 10:46:41 pm    Post subject:

Since you've pretty much tried everything already, you should probably go to a tech store and turn in your broken TI for a new one, assuming your warranty is legit and all.
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
    »
» View previous topic :: View next topic  
Page 1 of 1 » All times are GMT - 5 Hours

 

Advertisement