This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's Technology & Calculator Open Topic subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Calculator Tech Support => Technology & Calculator Open Topic
Author Message


Joined: 25 Aug 2009
Posts: 1

Posted: 25 Aug 2009 07:31:39 am    Post subject:

I have a problem trying to connect my TI-84+ to my computer.
I downloaded and succesfully installed TiLP2 on a windows (thx to some people on this forum) but I don't really know how to work with it.
I read the manual but think that maybe that won't help me solve the problem.

The program starts up as it should. (it looks as if it does)
I open the popup window and select change device.
I don't really know what kind of cable I have but since it is black, I choose BlackLink.
I don't really know which port to choose so I tried all of them, always a problem.
I have (as said before) a TI-84+ so I select that.
Timeout: 20
Delay: 10
USB scan at startup: V

And click OK
I get 2 errors:

Msg: unable to open serial port.
Cause: check that device is not used/locked by another application.
System: (1660976624) The handle is invalid.


Msg: attempting to use a cable which has not been open before.
Cause: Internal error.

What should I do?
Back to top


Joined: 25 Aug 2009
Posts: 1

Posted: 25 Aug 2009 01:34:39 pm    Post subject:

I assume you are using the USB cable. This cable is called "DirectLink", not "BlackLink".
Back to top

Advanced Member

Joined: 04 Oct 2008
Posts: 365

Posted: 26 Aug 2009 02:28:11 pm    Post subject:

Yup, correct. BlackLink is a serial cable. TiLP should recognize it, however. (I think there's a button to make the program figure it out for itself)
Back to top


Joined: 25 Sep 2009
Posts: 1

Posted: 25 Sep 2009 07:29:19 pm    Post subject:

I am posting my problem in this thread since I am getting the same error, but for a different reason.

I have a TI83+ that I am trying to connect to my PC using the SilverLink USB cable. I have installed TiLP2 and all required supporting software. I am able to open TiLP and connect to the calculator. I am able to press the Dirlist button and get info back from the calculator. My problem is when I try to backup the data from my calculator I get a timeout error, and when I try to send a new app to the calculator, I get this message:

Msg: error occured while reading to the device.
System: (1660976624) The handle is invalid.

Is there something obvious that I'm missing? I can't seem to figure out why this is happening. When I try to send data to the calculator, I put it in receive mode since if I don't, I get this error:

NACK received.
Cause: the command has been refused.

Please help!
Back to top

Advanced Member

Joined: 22 Aug 2008
Posts: 472

Posted: 25 Sep 2009 11:44:29 pm    Post subject:

I have no idea what the error message means, but no, you should not put the calculator in "receive" mode when transferring files to/from a PC. "Receive mode" is required for calc-to-calc transfers, but doesn't work for PC-to-calc transfers. (Yes, this is stupid.)
Back to top


Joined: 17 Jun 2009
Posts: 6

Posted: 26 Sep 2009 03:12:40 am    Post subject:

You know, i have ti84+SE and used to have tilp2... I was able to back up the files, but then could not receive the backup files, saying that it has an invalid name... So i changed to TI-Connect after many helps from various sources... Anyway, @ jayguad, for the application timeout, it might be that there isn't enough Archived memory in the calculator... for TiLP, they don't go like "insufficient memory" they go like "The handle is invalid"

Sooooooo... if it's possible, change it to TI-Connect... TiLP also didn't support recieving pic vars too.

Hope it helped.
Back to top

Advanced Member

Joined: 04 Oct 2008
Posts: 365

Posted: 26 Sep 2009 04:37:39 am    Post subject:

DON'T put it in recieve mode when using silent link. (what TiLP does)

"handle invalid" has something to do with the ticalcs library, I think. (there is a struct calchandle or something...)

About the NACK, I don't know what it means. I think it's a no-acknowledge packet or something.

Last edited by Guest on 26 Sep 2009 04:38:00 am; edited 1 time in total
Back to top

Active Member

Joined: 25 Jul 2006
Posts: 700

Posted: 26 Sep 2009 12:09:36 pm    Post subject:

I'm not sure if this is your problem, but for me, I can't send/receive more than 32 files at a time (this counts the number of files in a group, so if a group has 5 files, it counts as 5 files). Try sending at most 32 files at a time and see if that helps.
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» View previous topic :: View next topic  
Page 1 of 1 » All times are UTC - 5 Hours