This is an archived, read-only copy of the United-TI subforum , including posts and topic from May 2003 to April 2012. If you would like to discuss any of the topics in this forum, you can visit Cemetech's Technology & Calculator Open Topic subforum. Some of these topics may also be directly-linked to active Cemetech topics. If you are a Cemetech member with a linked United-TI account, you can link United-TI topics here with your current Cemetech topics.

This forum is locked: you cannot post, reply to, or edit topics. Calculator Tech Support => Technology & Calculator Open Topic
Author Message
Authentic INTJ

Super Elite (Last Title)

Joined: 25 Nov 2004
Posts: 3976

Posted: 12 Aug 2009 09:58:30 pm    Post subject:

So, I switch on my TI-84+SE for a bit of number-crunching, find what I need, then promptly turn it off. Less than a minute later, I hit the [ON] button again, but it doesn't seem to respond. [ON], [CLEAR], [CLEAR], [2nd], [MODE], [2nd] [[font="courier new"]▲]... Hmm, this isn't good. Is it the batteries? The device hasn't complained in recent uses... Reluctantly, I open the back, roll the cells, and try again. Nothing.

I cringe at what I am about to do next: I pluck out the batteries, tap [ON] a few times, and throw them back in. Still no dice. Argh! Did the back-up get jostled somehow? I spend a minute searching for a screwdriver, but can't find one small enough. Desperate and irritated, I return to the machine and push the [ON] button, just hoping for a bloody miracle. And the thing turns on.

No "RAM cleared" message, and all the programs are still there. Lovely. Of course, the clock has been reset... but under what circumstances? Could something like the 2038 problem have something to do with this? I run startTmr and subtract the 60 seconds that I spent looking for the screwdriver. Now, 60 seconds to a minute, 60 minutes to an hour, 24 hours to a day, 365.25 days to a year...

126230397/60[font="verdana"]²/24/365.25 = 3.9999999049

Did my calculator just choke four years after its activation in the factory? ...In fact, no, it didn't. The truth is that startTmr has its value based on whatever day/month/year is currently set on your calculator (something that you can change at will), thus it doesn't have any bearing on this issue. But, it still doesn't answer what happened to my calculator today.

Last edited by Guest on 05 Jul 2010 08:15:47 am; edited 1 time in total
Back to top

Advanced Member

Joined: 13 Mar 2004
Posts: 423

Posted: 13 Aug 2009 01:33:31 pm    Post subject:

I don't have a clue about what could've happened, but the clock does reset when you pull the main batteries. The backup battery for some odd reason doesn't keep the clock powered.

Do you have any strange ASM programs on your calc? A listing of your applications (and probably which ones you might have "installed" for those that do) might be helpful.

EDIT: The calcs do not seem to suffer from this 2038 problem as there's no 32-bit signed math that I can see the calculator doing. I've got the timer to go past year 2100 after some messing around with the timer ports, trying to figure out how high the thing could go.

Last edited by Guest on 13 Aug 2009 01:35:35 pm; edited 1 time in total
Back to top
Display posts from previous:   
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» View previous topic :: View next topic  
Page 1 of 1 » All times are UTC - 5 Hours