The mini-USB cable is a standard mini-USB cable; that's not the problem. I also seriously doubt a dependency issue, as Brass and rabbitsign are both standalone executables, and I build Doors CS in Windows 7 64-bit just fine. Can you post the contents of your build script, and the output it currently produces?
This is the .asm file I am trying to assemble:


.binarymode ti8xapp                 ; TI-83+ Application

.variablename "App Demo"            ; Application name (shown in 'Apps' menu)

.inclabels "ti8x.lbl"               ; Label file containing equates

.deflong bjump(label)               ; Jump macro
    call BRT_JUMP0
    .dw label

.deflong bcall(label)               ; Call macro
    rst rBR_CALL
    .dw label

.defpage 0, 16*1024, $4000          ; Page 0 definition

.page 0                             ; Start page 0
                                    ; ← header is added in here for us
    .block 128                      ; Advance 128 bytes for header

        bcall(_ClrLCDFull)          ; Clear the screen

        xor a                       ; Reset the -
        ld (curCol),a               ; cursor column and the -
        ld (curRow),a               ; cursor row.

        ld hl,TextString            ; Copy from...
        ld de,saveSScreen           ; Copy to...

    -   ld a,(hl)                   ; Copy the string to RAM
        ld (de),a
        inc hl
        inc de
        or a
        jr nz,{-}

        ld hl,saveSScreen
        bcall(_putS)                ; Display the string

        bcall(_getKey)              ; Wait for a key

        bjump(_JForceCmdNoChar)     ; Exit

        .asc "This simple app."
        .asc "just displays a "
        .asc "bit of text on  "
        .asc "your calculator "
        .asc "screen.",0

I use the following batch file (.bat) to automate the tasks for me:


Brass.exe Test.asm
rabbitsign.exe -k 0104.key -g Test.hex

Brass spits out this error when I try to assemble Test.asm:

Error: Could not sign application: Retrieving the COM class factory for component with CLSID {89F8F7D6-C4E0-4B68-99A1-18C894D67A36} failed due to the following error: 80040154

Yet a .hex file is still created (I'm assuming an incomplete one). Rabbitsign runs perfectly with no errors. The key file and the lbl file I use are fine. I found a thread similar to this one where somebody encountered the same error, with the same calculator model (TI84+).

Thread link:

I also found this:

But I don't think it addresses my specific problem.


I am pretty sure this is the underlying cause of the communication error I keep receiving. You were right in that my USB transmits data correctly, so this has to do with Brass and how it assembles the code.

The error is because you haven't installed (and configured) the TI-83 Plus SDK. Once installed, follow the instructions in the previous tutorial link:

You need to run Wappsign. It should be listed somewhere in the TI-83 Plus Flash Debugger start menu entry, or in the \Utils subdirectory of the Flash Debugger's installation folder. For signing to work, the Wappsign application needs to know where your key file resides. Click the [...] button next to the 'Key File' box, then browse for the 0104.key file. Click 'Yes' on the 'This directory is not in your search path. Add it now?' dialog box. Tick the 'Save Settings on Exit' box, then click 'Close'.

However, if the signing fails for whatever reason you should still have a usable .hex file (which can then be signed in Rabbitsign or similar).
I don't follow. I have installed the TI-83 Plus SDK (I'm not sure what you mean by configured, I followed through with the installation wizard). I use the 0104.key when signing my hex file, and I have tried Wappsign, only to get the same Communication error when sending the .8xk app to my device. I think it has to do with how Brass assembles the assembly code in the first place (maybe the assembly code has something missing in it?). The hex file seems to be the problem, not the signing itself.

Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 2 of 2
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum