Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
flyingfisch wrote:
This doesn't work in IE8, I'mon my dad's computer so I have not tried it in chromium, opera, or firefox. It looks pretty good though. Smile
Thanks! Unfortunately, Microsoft isn't implementing the File API until Internet Explorer 10, which I'm sure jsTIfied told you about.
Yes, jsTIfied told me all about it Very Happy
I have tried it quickly on Google Chrome on a Mac. The keypad does not work at all. Nothing shows up on the screen (and yes I pressed [ON]. Just saying this because I had forgotten to press [ON].)

So Google Chrome hates you. Maybe.... Try writing it as a Chrome add in? Not sure how much harder that is. but it is worth a shot if you want to put that work into it.
You can also just click on the screen to turn it on, and then use the PindurTI key bindings to control it until I get this figured out.
OK. Will have to search PindurTI then. Clicking the screen also does not work for me.
Aes_Sedia5 wrote:
OK. Will have to search PindurTI then. Clicking the screen also does not work for me.
You followed the instructions to load a ROM image, right? Also, the PindurTI key mappings:

http://wikiti.brandonw.net/?title=PindurTI#Basics
KermMartian wrote:
Aes_Sedia5 wrote:
OK. Will have to search PindurTI then. Clicking the screen also does not work for me.
You followed the instructions to load a ROM image, right? Also, the PindurTI key mappings:

http://wikiti.brandonw.net/?title=PindurTI#Basics

It might be helpful to have those on the jsTIfied site somewhere as well.
elfprince13 wrote:
KermMartian wrote:
Aes_Sedia5 wrote:
OK. Will have to search PindurTI then. Clicking the screen also does not work for me.
You followed the instructions to load a ROM image, right? Also, the PindurTI key mappings:

http://wikiti.brandonw.net/?title=PindurTI#Basics

It might be helpful to have those on the jsTIfied site somewhere as well.
Definitely agreed. My current occupation is rushing to implement file sending.
In Chrome and Firefox, using a valid ROM (works on Wabbitemu, at least) doesn't work. When I turn on the calc, it gets stuck at "Defragmenting..."

The famous "z.rom" works though. Smile

(Interestingly enough, WebWabbitemu also doesn't work with the TI-83 ROM I supply it, but works with the z.rom.)
KermMartian wrote:
Aes_Sedia5 wrote:
OK. Will have to search PindurTI then. Clicking the screen also does not work for me.
You followed the instructions to load a ROM image, right? Also, the PindurTI key mappings:

http://wikiti.brandonw.net/?title=PindurTI#Basics




*facepalms* no.. I did not put a rom in there... Aes feels dumb now. I tried to get roms before, and they never work for me.. Maybe i will try it again.
This is what i get when I use the TI83plus.ccl

[img]http://www.zimagez.com/miniature/screenshot-02072012-052705pm.php[/img]
flyingfisch wrote:


What's a .ccl? if you're talking about the .clc files that TI distributes with their SDK, I'm pretty sure they aren't proper ROMs.
elfprince13 wrote:
flyingfisch wrote:


What's a .ccl? if you're talking about the .clc files that TI distributes with their SDK, I'm pretty sure they aren't proper ROMs.


Oh, ok. Someone told me they were...
What ROM version and which calc model do I need in particular? Because all I had were TI-84 Plus 2.41 and 83+ 1.16 ROMs handy and none worked (blank screen for 84+ and black screen for 83+). I use Opera by the way.

EDIT: Actually on the 3rd reload, 83+ 1.16 emulation finally worked! Sending Zelda: Dark Link Quest files gives Failure Value 2 error, though, and I am unable to send multiple files at once (which might be a bit of a problem if I want to send BASIC games to the emulator)
flyingfisch wrote:
Oh, ok. Someone told me they were...

There is more information in the file than just a ROM. Some emulators can read them, some can't. Information on the format probably exists somewhere, but I've never looked into it.
Alberthro: there's apparently a broken ROM that a certain website is distributing. Obviously it doesn't work. What's a WeBwabbitEmu?

Elfprince: I believe Benryves said he was able to use the .clc as-is.

DJ_O: Once again, file loading is still in the process of being implemented.
KermMartian wrote:
Elfprince: I believe Benryves said he was able to use the .clc as-is..

Huh, fair enough.
elfprince13 wrote:
KermMartian wrote:
Elfprince: I believe Benryves said he was able to use the .clc as-is..

Huh, fair enough.
Don't look at me; I'm just as confused as you. Smile I have some suspicions of why it works, but nothing I feel like sharing, nor have I verified that it does indeed work. In other news, I embedded CalcSys in a ROM image and I'm using that on jsTIfied to debug silent-link-sending files to jsTIfied. I find it pretty cool.
The additional information in the .clc appears to be at the end of the file, not at the start. If your code assumes that the .clc file is exactly 512KB then you'll run into problems, but otherwise it should work (and does, currently). I think part of the confusion might arise from your working on the code in situ, as it stopped working earlier for me (black screen) but is now working again without me changing anything.
benryves wrote:
The additional information in the .clc appears to be at the end of the file, not at the start. If your code assumes that the .clc file is exactly 512KB then you'll run into problems, but otherwise it should work (and does, currently).
My code copies the first 512KB out of the ROM file, but it blithely runs along regardless of how big the file actually is. Actually, I was going to add some checks, but based on that it sounds like I should just make sure it's at least 512KB.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 2 of 8
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement