» Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 27, 28, 29  Next
» View previous topic :: View next topic  
Bug I found:
When creating an AppVar, I selected to make the AppVar protected. I think you should remove that option for the AppVars.
Yes, this does indeed to be the case. When it is protected, the AppVar appears inside the PGRMS menu... how odd. Smile
Unicorn wrote:
Bug I found:
When creating an AppVar, I selected to make the AppVar protected. I think you should remove that option for the AppVars.

MateoConLechuga wrote:
Yes, this does indeed to be the case. When it is protected, the AppVar appears inside the PGRMS menu... how odd. Smile

Thanks. This has now been repaired with two tweaks:
1) The Unlocked/Locked selector is no longer shown when editing AppVars and Strings, only when editing Programs.
2) Exporting any file type with the program Locked/Unlocked selector set to Locked will only export a Locked Program if the filetype of the data being turned into a binary is a Program or Protected Program.
KermM++ for your awsome sourcecoder, as i said earlier, but the emulator (using TI-84+, 2.55MP, zstart and Axe), fails often to transfer data from source coder to it. Only a ram or total reset fixes the issue, but it is really annoying.

Heres a quickfix for Google Chrome users:
Open the Javascript console and paste the following snippet:

Code:
fix_zstart = function(){resetcalc(); setTimeout(function(){press_onkey()},500); setTimeout(function(){clickKey(0x46)},1500); setTimeout(function(){clickKey(0x21)},2000); setTimeout(function(){clickKey(0x43)},2500);}

To run it just bind the function "fix_zstart()" to one of the buttons of jstisfied or to one of the ide. Whenever the calc glitches out, enter fix_zstart() into the console or press the button.

And if you want a quick axe compile and run with the fix from above, use this code, paste it in the chrome developer console and bind the function "compile()" to one of the "send to jstisfied" buttons:

Code:
function compile(){resetcalc(); setTimeout(function(){press_onkey()},500); setTimeout(function(){clickKey(0x46)},1500); setTimeout(function(){clickKey(0x21)},2000); setTimeout(function(){clickKey(0x43)},2500); setTimeout(function(){sc3js_putfile()},3500); setTimeout(function(){ex=function(pname){list=ti_common_get_listing();if(list.length == 0)return false;else if(list.length == 1&&-1==list[0][0])return false;else for(line in list){data=list[line];size=data[0]+256*data[1];name="";if(data[3]==78||data[3]==84) {for(i=3;11>i;i++)if(data[i] > 0)name+=String.fromCharCode(data[i]);else break;if(pname == name)return size;}}return false;};if(ex(proj.files[proj.projectCurIdx].name)){setTimeout(function(){clickKey(0x36)},1000); setTimeout(function(){clickKey(0x02)},1500); setTimeout(function(){clickKey(0x42)},2000); setTimeout(function(){clickKey(0x31)},2500); setTimeout(function(){press_onkey()},3000); setTimeout(function(){clickKey(0x61)},3050);}else{alert("Compilation failed!")};},8000);}

when you click the button or run the command it will send the current file to the calc, fix it, compile the current file and run it

and heres the same thing as above but for projects (the currently open file will be the start file)

Code:
function compile_proj(){resetcalc(); setTimeout(function(){setTimeout(function(){press_onkey()},500); setTimeout(function(){clickKey(0x46)},1500); setTimeout(function(){clickKey(0x21)},2000); setTimeout(function(){clickKey(0x43)},2500); setTimeout(function(){sc3js_putproj()},3500); setTimeout(function(){ex=function(pname){list=ti_common_get_listing();if(list.length == 0)return false;else if(list.length == 1&&-1==list[0][0])return false;else for(line in list){data=list[line];size=data[0]+256*data[1];name="";if(data[3]==78||data[3]==84) {for(i=3;11>i;i++)if(data[i] > 0)name+=String.fromCharCode(data[i]);else break;if(pname == name)return size;}}return false;};if(ex(proj.files[proj.projectCurIdx].name)){setTimeout(function(){clickKey(0x36)},1000); setTimeout(function(){clickKey(0x02)},1500); setTimeout(function(){clickKey(0x42)},2000); setTimeout(function(){clickKey(0x31)},2500); setTimeout(function(){press_onkey()},3000); setTimeout(function(){clickKey(0x61)},3050);}else{alert("Compilation failed!")};},15000);},1000)}

You can use both at a time. If you only change the main file, use the compile() function and if you change other files use the compile_proj() function.

And I suggest to add the abelicities to it:

- be able to quickedit sprites that are a multiple of 8 but not square
- show a table for Axe data fields (popup) with a selectable width so that you can edit your data easier than making such a chart on a piece of paper or Excel and then transfering.
- the on key of the calculator really needs a physical keybind, especially for axe-development.

--Muessigb
Muessigb wrote:
KermM++ for your awsome sourcecoder, as i said earlier, but the emulator (using TI-84+, 2.55MP, zstart and Axe), fails often to transfer data from source coder to it. Only a ram or total reset fixes the issue, but it is really annoying.
It sounds very much like this is a zStart issue to me. Have you tested to see if this still happens with zStart removed?
Well I resolved the issue, by disabeling fast mode (which was automatically started somehow). I found the icon of the fast mode a little bit hard to understand. I would have used a white flash for no fast mode and a filled for fast mode.
Muessigb wrote:
Well I resolved the issue, by disabeling fast mode (which was automatically started somehow). I found the icon of the fast mode a little bit hard to understand. I would have used a white flash for no fast mode and a filled for fast mode.
I agree that that icon needs to be made clearer. Thank you for the suggestion.
Thanks for solving that.
I have one more suggestion for fast mode:
If you upload files when fast mode is enabled, it should automatically disable fastmode during the upload and enable it later.
Seems like SourceCoder has problems parsing (or saving) programs that contains Stat plot or many slash characters:



After I made that screenshot, I edited my file on-calc then transfered it to my computer, then loaded it into SourceCoder and the source was fine. But then I re-sent it back to the calc after exporting from SourceCoder and it was back to the state it was in in the screenshot above.

Not sure which character is the culprit but this definitively is a SourceCoder bug, since even backslashes don't solve the problem. The cutoff is random, so that different combinations of characters will cut off at different places.

EDIT Seems like stat plot chars aren't the culprit. I have the feeling it's a very random bug occuring in random, hard-to-recreate occurences. In any case, it's a fatal bug.
It's interpreting those slashes as //comments. Use the backslash delimiter (\) to divide double forward slashes.
Ah right I see now. Thanks
In Axe mode WRect( tokenizes to something like W!?(
Also when loading a project, it should auto-detect the language, like it does when uploading a file.
Yes to what Muessig said about bug and loading a project thing.
When sent to the calc WRect() is seen as W!? for me.
There is an issue with importing TI-Basic Hybrid CSE programs from jsTIfied to Sourcecoder. The real(# commands are converted to different tokens such ClearScreen(, RunIndicator(, and DrawTileMap(.
These are the equivalents of the non-color xLib.

Also, when working in a project, pressing the Ctrl-Z shortcut deletes/replaces code from a program. First, create a program and add some code. Then, add another program to the same project and add different code. Go back to the first program and trigger the shortcut. The code from the second program should replace the code on the first program.

When transferring a program to jsTIfied, DoorsCSE cannot be actively running (i.e., TI-Basic Editor Enhanced, Error Menus, or DoorsCSE's homescreen). If you try to, jsTIfied will say that the program failed to load, while Sourcecoder will say that the file has been succesfully transferred.
I have two bugs

First, the bbcode box doesn't disappear when clicking off
Second, when pulling jsTIfied out from the right side, the screen is black and only works if I upload a file from my HD

EDIT: It also parses "WRect" for Axe as "W?!"
Is there any way to get backslashes to properly show up in a program?
Bug:

If you comment out in the first line, they will carry over to the Calculator when you click to transfer into jstiFied. I haven't tested if it transfers over to a Connected by USB Calculator or into an Exported File.

1: //Comment 1
2: //Comment 2

Comment 1 will transfer over and give a syntax error, while Comment 2 won't

Found April 24, 2015 at 8:50 CST PM
When transferring a program to jstified, it always shows the message that the file transferred correctly, even though sometimes it does not. In the jstified settings, it shows failed or complete correctly.
Mention this before in SAX, but sometimes the Axe app deletes itself when I compile something, and even sometimes when I just run it. This has never happened before on the actual calc nor on wabbit. Using Axe ver 1.2.2 if that matters.
Here's a screenshot from jstified:
It's defragmenting which is you issue. For some reason axe struggles tremendously with that when emulated. I would contact axe devs with this because it happens on wabbit as well (its less bad in jstified).
Doing almost anything in SC using IE 10 gives an "Are you sure you want to leave this page?" message. Clicking "Leave this page" does not actually leave the page (except, of course, when leaving the page is intended). I have confirmed that Firefox does not have this problem.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 27, 28, 29  Next
» View previous topic :: View next topic  
Page 20 of 29
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement