Today, we had a very insightful discussion on HCWP about CALCnet, specifically trying to connect some calculators to it which has proven to be substantially more challenging than I had imagined. There were some issues related to the server not responding and some code in a newer version of SAX causing issues. Botboy3000 finally managed to connect his ti-83 through his Photon (a Wi-Fi module), while I am still experiencing issues with simple old direct USB. Currently, Gossamer seems to be misbehaving for Botboy3000. On my end, everything is set up and should work, but the gCn client can't seem to find my calculator, even after I set up the filter driver (It just searches for it to no avail). Hopefully, we can get it back up and running both on the Photon and by direct USB in the near future.
EDIT: It is the day after, as per geekboy, I reinstalled a different filter driver and ran GCNchat from within DoorsCS rather than the homescreen, and I got it working! Here is a screenshot of my calculator's first time on the interwebz.
I have made a discovery regarding WebHub and the particle Photon. After a series of resetting the photon and starting Gossamer, Only a fraction of the time did the progress bars show up in the Gossamer window. I have attributed the success of the progress bars' appearance to a specific light sequence on the photon.

Here are 2 videos, please ignore my little brother Razz

Correct light sequence:

Incorrect light sequence:
Little Update...
I just connected to FTBHub and downloaded a program off of ticalc for the first time. I did notice that you can't send flash apps though. I went to check in the little list Kerm provided and he states that you can transfer "programs, groups, pictures, matrices, lists, GDBs, AppVars, and strings" which means no flash apps. Why not..? Certainly, there must be some unknown restriction...
Besides that, still no hope on the Gossamer side, my calculator freezes up when I try to click it as if I had entered a hubname that does not match the program, but I've double checked and it is in fact "WebHub", at least in the documentation it is...
EDIT: I just tried "WEBHub" and that seems to be correct although the program freezed up in the loading page phase, and I can't seem to do it again, For some odd reason, when I try to redo it with either WebHub or WEBHub, they both just act as if the hubname was wrong.
EDIT2: I believe I found something interesting, the case where the program loads up and freezes at the loading page phase only happens when I run Doors from the apps menu. When I run doors using [ON][prgm], it freezes on the DCS homepage instead.
Here is the log from the case where it reaches the loading phase:

Calculator successfully reconnected.
Received 52 bytes
FFFFFFAA FFFFFFAA FFFFFFAA FFFFFFAA FFFFFFAA 0A 33 06 1A 4C 28 00 2E 68 74 74 70 3A 2F 2F 77 77 77 2E 63 65 6D 65 74 65 63 68 2E 6E 65 74 2F 67 63 6E 2F 70 6F 72 74 61 6C 2E 68 74 6D 6C
|0A33061A4C.AAAAAAAAAA,2800:2E687474703A2F2F7777772E63656D65746563682E6E65742F67636E2F706F7274616C2E68746D6C>Sending calc ID 0A33061A4C to server
Wrote 13 bytes to socket (connect msg)

              3     L  (    . h t t p : / / w w w . c e m e t e c h . n e t / g c n / p o r t a l . h t m l  Sending frame data of length 40 to server
Wrote 58 bytes to socket (frame msg)
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum