Ok earlier I was doing some simple math on my Ti Nspire in 84+ mode. And it froze, I had input 43^ and then it just froze up. No run indicator moving, natta. I tried:
1. Removing Keypad, putting it back in.
2.swapping keypads for the Nsipre touchpad
3.pulling batterys,
4.holding reset button for 5 seconds.
5.Pull batterys put keypad in hold reset for 5seconds as I turn on.
6. Tried connecting to TILP and TI Connect both of which do not work.
7.Tried turning on while holding 2nd + Del, 2nd Enter +DEL and a couple others as I could not remember what the special combo was.

I have no idea what to try, I would love a non ram clearing solution as I have done a lot of programming the past couple of days, with no backups. but I feel a non ram clear is out of the queestion at this point...
Hmm, I don't have an Nspire myself so I can't really help you much with your problem, but have you tried the key combos listed here?
I could not find those for some reason, I will try them!
Ok, So I tried those keys to pull up the screens, but nothing worked. The screens pulled up, but they did not jump start the emulator. So... I am going to break the OS, and downgrade. I have heard 1.6 is the best Nspire OS for using the 84+Keypad. IS this true? iirc Qazz42 told me, but not positive. I only use the 84+keypad so I would prefer the best OS for that.
ok so I reset the OS, upgraded all the way at parkerR's advice, I used the special tool so I can downgrade again. and now, it works with ONE BIG PROBLEM. I lost
1. my mathpack changes, (easy fix)
2. My calcopoly changes (Easier fix)
3. my related rates program (was barely started)
4. My derivative program (this sucks, was half way finished)

I know, back ups are important, but TILP flipping HATES me. takes an hour to get it to work, so I usually just backup in a group file, (lot of good that did) So now , I need to update TILP or something, so it will work the first time.
Backing up to a group file is a good start, but as you know, you need to back that group file up to your computer. You have to be more specific than "TILP hates me" if you want anyone to try to help you solve the problems.
Well tilp never sees my calculator, when it does see it, i alwYs get a cable error and i cant transfer files. "this cable is in use by another device" or something like that is the error. I tried every port and cable i own.

Excuse spelling and such. On my ipod.
I know the problem, I think. The nspire's 84+ emu, when it locks, hates you.

Two solutions:

Easy Way, lose files:
Use the reset button while it's on, and in 84+ mode, but frozen. Reset and lose archive

Slightly harder way: Keep files in archive (akin to a ram clear on a real one, and actually is immune to most that would also clear archive on a real calc)
Insert the keypad at an angle, such that the pins still contact.
Turn on the calculator
Remove batteries (make sure the rechargeable is already out if you have one, or remove it instead) Calc should shut off
Remove keypad, put batteries back in, and turn on. You should have a ram clear. Wink

In this way, you can feel much safer by simply archiving everything. Backups are still important, though, but I haven't lost a single file since I started this method.
Hmm. Thanks, _now_ you tell me Razz I am not sure how to put it in at an angle, I can only get it to go in straght? Does it have to barely make contact to turn on? Also, I tried the reset button with and without the 84+ Keypad and it did no good. I just need to get TILP working for me. Although, *winks at Kerm* if the bridge to cemetech backups gets working, i wont need TILP. *prods Kerm to do that* Very Happy
hmm.....the reset button normally works....that's odd.

it's maybe a 20 degree angle, not as much as you expect. the contacts just need to be touching, but it's not as precarious as you'd expect.
OK I will try that next time. For now I am working on getting TILP to work... I will post a topic later on.
Of course. There is always going to be an unforseen circumstance or three Razz
Yes of course. or 5 as is often the case.
Here's what I do:
I hold in reset, which only restarts the calc. When it shows the "TI-Nspire(tm) TI-84 Plus Silver Edition" screen with the three rectangles flashing in sequence, I hold in all four arrow keys, which will make it do a ram clear. It's saved me from unresponsive asm programs and problems not unlike yours all the time ^_^
yes but I was not running a program at all. .. It was simple math. so not sure if that would have worked.
It should. My calc just randomly froze one day (actually this morning) and I just used that.
oh ok. The problem was, all my stuff was sitting in ram, so it would not have mattered anyway... Sad
DoorsCS allows you to run stuff as if it was in RAM even if it's in the archive. The only exception I'm aware of is BBC Basic programs, which still need to be in RAM.
willrandship wrote:
DoorsCS allows you to run stuff as if it was in RAM even if it's in the archive. The only exception I'm aware of is BBC Basic programs, which still need to be in RAM.
Precisely true. If you use the Doors CS BASIC headers on programs, it can even deal with a BASIC program's subprograms being in Archive.
Yea.. I usually use DCS because you dont have to scroll through code when you brreak a program.. it goes right there. But now I can put only the apps I want, and make sure there are no conflicts..
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum