Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
Nope, none at all, everything was smooth, except at first it wasnt sending until I noticed that my I/O cable would not fit into the nspire without some force (No "thats what she said" jokes @youknowwhoyouare)
Bug report:
Chat exits and outputs "@11057:51697" on my TI 83+SE, but runs perfectly on my TI 84+SE. Sad
souvik1997 wrote:
Bug report:
Chat exits and outputs "@11057:51697" on my TI 83+SE, but runs perfectly on my TI 84+SE. Sad
That's a MirageOS compatibility report; $2B31/$C9F1. That doesn't make any sense; are you sure nothing's corrupted? Are you running DCS 7.1.1? Try a RAM clear?
KermMartian wrote:
souvik1997 wrote:
Bug report:
Chat exits and outputs "@11057:51697" on my TI 83+SE, but runs perfectly on my TI 84+SE. Sad
That's a MirageOS compatibility report; $2B31/$C9F1. That doesn't make any sense; are you sure nothing's corrupted? Are you running DCS 7.1.1? Try a RAM clear?

Ah, I was running DCS 7.0.1. >.<
Heh, that'll do it. The CALCnet 2.2 drivers weren't re-introduced until Doors CS 7.1, as you probably recall.
Ok, I installed DCS 7.1.1, and it works! The only problem is that if you send a message at exactly the same time on both calculators, only one of the messages show up in the chat log. Also, could you make the chat log put the newest message at the bottom instead of the top and add a way to scroll back through chat logs?
souvik1997 wrote:
Ok, I installed DCS 7.1.1, and it works! The only problem is that if you send a message at exactly the same time on both calculators, only one of the messages show up in the chat log. Also, could you make the chat log put the newest message at the bottom instead of the top and add a way to scroll back through chat logs?
I'm afraid that would be much, much, much harder to implement, for a whole variety of reasons. Sad I'll try to replicate your bug with sending two messages at once; do both calculators at least agree on the final state, or no?
KermMartian wrote:
souvik1997 wrote:
Ok, I installed DCS 7.1.1, and it works! The only problem is that if you send a message at exactly the same time on both calculators, only one of the messages show up in the chat log. Also, could you make the chat log put the newest message at the bottom instead of the top and add a way to scroll back through chat logs?
I'm afraid that would be much, much, much harder to implement, for a whole variety of reasons. Sad I'll try to replicate your bug with sending two messages at once; do both calculators at least agree on the final state, or no?

Yes, they do.
Hmm, that's good to hear at least. The next big thing I need to do is make the Arduino give up on sending messages after a few attempts, like 40 or so.
Woo, this is pretty awesome Kerm, I cannot seem to make this crash....
qazz42 wrote:
Woo, this is pretty awesome Kerm, I cannot seem to make this crash....
Excellent! And with some gCn debugging tonight with my good friend and gmod Merth, I think the gcnclient is just about ready for a beta release!
Sad The computer electronics guy in my school did not have an Arduino

sadface
Here's a pic of it running Smile
Awesome, Shaun! Here's two more for everyone's viewing pleasure, although these focus on the hardware more than the software:



I just stopped by to see some updates, and I'm REALLY awed!
gCn making significant progress (gives C2I a need to catch up!), and now this? Very Happy

A couple of things:
1) Strangely enough, one calc asks for username, other one doesn't.
2) Duplicate usernames != fun (caused by #1's quirk - it sets the username to ABC from the first calc after I say something on the first)
3) Strange quirk with the messages appearing at the top of the screen. What's up with that?

Other than those issues, this program is giving me more reasons to work on my hub (and potentially, a wireless counterpart)! Congrats on this nice release! Very Happy

* On a side note, I'm extremely busy at the moment with plenty of midterms, essays, and just plain work. I plan on replying to that fun/messy topic I started 2 weeks ago, since a long reply deserves an equally long reply. Eventually, the topic might be split to start a mini brainstorm on things to aim for. But yeah, I won't be online for a considerable amount of time. Of course, you can always email me or FB me (and if you know me well enough, find me on FB). Good luck to everyone in the calc community! Very Happy I'll be back for sure in time for a Feb. 1st KnightOS release! Wink
Please, please, PLEASE give me more details. It's really hard to debug when I also have to interpret your reports. Razz

1) This is because you set the username on one calculator before sending it to the other calculator, since the username is stored in the program. Just go to Users -> Me to change your username.

2) What? Clarify, please?

3) It's not a quirk, it's how it works. SAX-style scrolling is about 1KB and weeks of headaches less and easier for me and Merth. This isn't going to change no matter how much you complain.

Cheers on the complements.
lol, for number 3 I thought he meant that random messages were flashing on the top or something
qazz42 wrote:
0x5, for number 3 I thought he meant that random messages were flashing on the top or something
I thought so too, until I read it a few more times and tried to think what might be more likely for him to say.
KermMartian wrote:
Please, please, PLEASE give me more details. It's really hard to debug when I also have to interpret your reports. Razz

1) This is because you set the username on one calculator before sending it to the other calculator, since the username is stored in the program. Just go to Users -> Me to change your username.

2) What? Clarify, please?

3) It's not a quirk, it's how it works. SAX-style scrolling is about 1KB and weeks of headaches less and easier for me and Mesrth. This isn't going to change no matter how much you complain.

Cheers on the complements.

1) This occurred after I sent the program without running it.
2) I suck at making details evident or perfect, so I'll try my best. Wink
After getting them connected and communicating, I've sent a message on the no-name 2nd calculator. After doing so, the first calculator indicated that ABC (the 1st calc's name) joined, but didn't show the message. After exiting and restarting, it seems that neither like to be synced, and only when conditions are right (no idea what they might be) it will post and recv. nicely.
3) Aw... I thought it was an actual bug for an instant. At least could you give me an excuse to tell my friends about why it scrolls up? Wink
Well yeah, because they were both named ABC. It was correct in thinking that ABC joined. I just tested two Chat instances with the same name and found no problems.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 2 of 3
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement