Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
Here we shall keep track of what games/programs that utilize xlib to function. Post what games you try and whether they pass or fail. If they fail, Please describe what it is that they do, and post a screen shot if possible.

Games that pass compatibility:
:: Metroid Infinity by bsparks/CDI.
:: Super Mario Smash Dance by DJ Omnimaga.
:: XLib XLib Revolution by DJ Omnimaga
:: Metroid BASIC v1.001 by bsparks/CDI. Repaired by fixing Pic "0" -> Pic0 = Pic "10" bug in real(2)

Games that fail compatibility:
none known
As tifreak said, please test XLib/Celtic programs and report the results in this topic. If the program works well, great, let us know. If it fails, please try to describe the failure symptoms, along with (if possible and necessary) a screenshot.
*bumpity bump* With some help from Iambian, fixed the problem with CDI's Metroid v1.001. Celtic's real(2) clone was improperly changing Pic "0" to Pic "8" = Pic8 instead of Pic "10" = Pic0.
http://www.ticalc.org/archives/files/fileinfo/427/42763.html


Tested that

With Parser hook it only displayed text, no graphics or anything, just text.

Executing it normally (disabling parser hook) causes it to run fine. GASP Surprised!!!


EDIT: Tried http://www.ticalc.org/archives/files/fileinfo/411/41140.html


No.... just no, it is missing all graphics, it does not go past the begining page.... just... no
...it would actually be interesting to write a program that tests compatibility, akin to Acid3...
rthprog wrote:
...it would actually be interesting to write a program that tests compatibility, akin to Acid3...
Rthprog, that would indeed be pretty nifty!

@Qazz, good stuff, I'll check those out as soon as I finish working on solving this issue with FileOpen/FileSaveAs with Anak.
K, this seems to be a pattern with Xlib prgms, all graphics are barely screwed or completely screwed
qazz42 wrote:
K, this seems to be a pattern with Xlib prgms, all graphics are barely screwed or completely screwed
"all graphics"? By contrast, every single XLib game I've tried with the exception of Metroid v1.001 has looked fine, and I fixed the issues with that game yesterday.
qazz42 wrote:
http://www.ticalc.org/archives/files/fileinfo/427/42763.html

Tested that

With Parser hook it only displayed text, no graphics or anything, just text.

Executing it normally (disabling parser hook) causes it to run fine. GASP Surprised!!!
Age of Culture v0.89 worked flawlessly for me under Doors CS.
*bump* And I had no problems with the xLib BlokDude game, either. Text and graphics were both fine. :/
This xLib problem is the same issue I have been having with my current Fable: TLC game I'm working on. The text( command erases the graph screen upon it's first encounter. Unfortunately, I had to revert back to the standard xLib and remove DCS7 compatibility...until this is fixed...
zeromp wrote:
This xLib problem is the same issue I have been having with my current Fable: TLC game I'm working on. The text( command erases the graph screen upon it's first encounter. Unfortunately, I had to revert back to the standard xLib and remove DCS7 compatibility...until this is fixed...
Can you send me a sample program with the bug to test?
Is that the same bug as during Reuben Quest: Ev Awakening title screen menu?
DJ Omnimaga wrote:
Is that the same bug as during Reuben Quest: Ev Awakening title screen menu?
It might be; I'm not positive until I see his code. Until you mentioned it, I didn't think it was the same, because yours looked like an Output + image splitscreen issue, and his is Text(). Is yours instead Text(-1 on the graphscreen?
Oh, right, I forgot this part of my game used Horiz mode to have both home screen and graph screen. My bad x.x
DJ Omnimaga wrote:
Oh, right, I forgot this part of my game used Horiz mode to have both home screen and graph screen. My bad x.x
It's still possible that it's slightly related, but I think yours may be a different unfortunate interaction of TI-OS flags and modes.
modu10 by Nitacku : FAIL

http://www.ticalc.org/archives/files/fileinfo/419/41986.html

screenshot
It seems like the code is corrupted, did you try re-sending the program?
souvik1997 wrote:
It seems like the code is corrupted, did you try re-sending the program?
As Souvik says, you seem to have a corrupted copy of the program, unfortunately. Perhaps we can ping Nitacku on IRC and get him to take a look.
Yes 2 times, to my calc a few times, and to wabbit a few times as well. it is not corrupted before playing i checked that as well.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement