My TI-84+CE Will Only Work When Plugged in. When unplugged I click the on button & the screen flickers but turns off, but right when I plug it in the screen turns on. I have tried pushing the reset button, But that didn't help, It says there is no Power, but it has been charging for hours.

I am Using TI-84+CE
I think your only option left is to replace the battery.
When buying an used calculator that uses bombs to power themselves it's often unclear if the previous owner(s) were knowledgeable about lithium-ion explosives such as making sure not to let the calculator sit at 0% charge for weeks at a time. My older CE used to remain at 100% charge for years without charging it and nowadays I have to charge it every month or so.
Well It randomly turned on & worked today(without charging it, because I gave up) , I think there is a loose connection, because sometimes when is supposedly charging the light will start changing between green, red, & orange at random times. I am not even sure how old the calculator is. I don;t remember what version it was at when I got it but my teacher made as all update to 5.8, but I downgraded it to 5.3 about a month ago. (I know when I got it it was newer that 5.3 but older than 5.7)
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum