Hi, I'm new to this forum and not great at forums in general so sorry if this is the wrong place to post this.

I recently got a ti-84 plus ce with python and I immediately went to program on it. I started with the CE C/C++ toolchain and was doing pretty well. I'm not super familiar with C so I was struggling with properly utilizing pointers, but I managed to get the hang of it. However, anytime I try and connect the calculator to my computer, something wrong happens.

Whenever I would transfer an compiled program to the calculator, TI Connect CE would crash. Anytime I tried to check the apps or appvars, the program would crash. I tried using TiLP, but it kept giving me cryptic errors. I saw some other forum posts trying to help with the error message I was getting, but it didn't help (although I found out that maybe it was because I had both TI Connect CE and TiLP installed). I checked the connected devices to my computer and deinstalled and reinstalled the drivers multiple times, as well as reinstalling TI Connect CE multiple times, but the problem persisted.

For a while, my computer wouldn't even recognize the calculator as a USB device, but it does now.

I'm mainly worried that I messed up bad with my programming abilities and ruined something by messing with something in memory that I wasn't supposed to. Whenever I use TI Connect CE to transfer my programs to the calculator, the programs still transfer, but it crashes. The calculator (seemingly) functions as normal. I have no idea whats going on please help.

Thank you for any help I get. I have no idea what I'm doing lol.
Does transferring a normal .8xp work?
It's nearly impossible to mess up your calculator writing programs or running them. If you ever need to reset the USB for some reason, press and hold the reset button on the back for 10 seconds.

As for why your program crashes, it's most likely a coding error. Providing your code or a link to it would be helpful.
graph100 wrote:

That's weird, it's most likely a library dependency or clibs isn't installedz though I wouldn't be too sure. The source and makefile would be helpful.
Its not my programs that are crashing but TI Connect CE. All my programs seem to work fine.
What OS are you using TI Connect CE on? The Chrome OS version has been noted to hate any protected programs that are sent through.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum