A few months ago, I got a Casio FX-9750GIII. Around that same time, I was testing a program on it, and it froze in the middle. I tried turning it off, nope. I tried pressing the reset button, nope. Then I took out a battery, then it turned off. I tried turning it back on again, and it done nothing. I let it sit for a few months and put fresh batteries in it, HEY IT CAME BACK TO LIFE! I shouldn't have got excited because I turned it off, and it froze on the splash screen. Guess what? IT DIDN'T TURN BACK ON! To this day it still doesn't work. Does anybody know how to fix it?

Thanks in advance!

P.S. I asked this same question on the Universal Casio Forum a while back, but unfortunately HappyCalc's method didn't work for me.

Edit: My friend got the main menu to display for a split second today, but it almost immediately faded away .
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum