I am not really known with video things graphic stuff of how that all works.
I want to play a game that needs something with Radeon or something like that. But it seems like I don't have that.
I have an Intel video chip.
Is there still a possible (hacky) way I could play that game?
Well, if it needs features provided by the Radeon chipset, then the only way that seems possible is to port the game to not use Radeon. Maybe port it to a calculator 😏
There are very few programs that actually depend on a given vendor's GPU specifically, but I suspect your game lists some particular GPU as a requirement that you don't meet.

You'll have to provide more information on what specifically you're doing (what program you're trying to run, perhaps) and how it doesn't work.
I want to play Fer.al (https://fer.al).
It is currently not available for Linux, but I got it running using Wine.
The problem is that I see just grey instead of stuff...
It appears that the game requires a GPU of equal or greater capability to the Radeon 7000 series. The grey could possibly be an issue in wine, not an issue of lacking GPU power. There probably isn't a hacky way to use it with integrated graphics but I don't really know much about that kind of thing so don't take my word for it.
Hmm. I just asked around in the official Discord of Fer.al....
It appears they haven't ever seen something like this, so it would then very likely be an issue with wine, they say.
Maybe I should just try to put Windows in a VM...
I once tried to get Windows 10 in a VM but then it didn't work?
And Windows costs money right?
Windows 10 does indeed cost money, but there is also a free download available IIRC. If you're going to run it in a VM you might as well just dual-boot install it instead and get better performance.
Dual-booting wouldn't be possible.
My father won't agree with that.
He doesn't want anything Microsoft on my laptop.
So I would really have to use a VM.
Privacy_Dragon wrote:
Dual-booting wouldn't be possible.
My father won't agree with that.
He doesn't want anything Microsoft on my laptop.
So I would really have to use a VM.

In that case you can download the free version of Windows 10 from the Microsoft site and install it in a VM. It won't be as good as physically installing but it will be much easier. Depending on your laptop specifications (RAM, CPU, etc.) it will probably work decently well. Also: If your dad doesn't want anything Microsoft on your laptop, then would he be okay with installing Windows in a VM?
This does sound like it's probably a Wine problem rather than a GPU problem.

A VM won't help you much because you typically won't get graphics acceleration by default- 3D performance will be bad at best unless your hypervisor supports some kind of 3d acceleration, either in the form of paravirtualization or API forwarding, and even then it will be worse than running natively. Sorting those things out is pretty complex but might be made to work.

Depending on what Linux distribution you're running, you might have a pretty old version of Wine where a newer one may work better. Do you know what distro you're using?
Might it really be the issue that I have an old version of Wine?
Well, I can use Junest maybe to see if that's true...
My system is pretty out of date, since the distro version I'm using isn't supported anymore....
My father wants to update, but he first wants to finish his back-up script, which is not going really fast...
Try doing `wine --version` and see what output it gives you. The latest download on the website appears to be 6.0.1, which is newer than what I remember, so maybe I should update... Rolling Eyes

Also, what does your Wine setup include? Installing Winetricks, DirectX 9, running in Windows 7 vs running in Windows 10 mode, and other things might help as well. But of course it is always generally a good idea to update if you can.
I have installed winetricks and several things. Didn't help.
I am actually using a pretty old wine version...
But that is the one supported for my linux distribution...
Privacy_Dragon wrote:
I have installed winetricks and several things. Didn't help.
I am actually using a pretty old wine version...
But that is the one supported for my linux distribution...

Have you tried using something like PlayOnLinux? I'm not sure how much of a different result you would have but PlayOnLinux seems to be for gaming so it might work better. Otherwise, what is the distro you are running? It might be advisable to update or switch to a more recent distro such as Manjaro or Ubuntu. (If you're not already using one of those)
I did try PlayOnLinux, but I couldn't get it working.
Yeah, my distro version, OpenSuse Leap 15.1, has reached end-of-life. So I don't know. Maybe updating to Leap 15.3 would work. My father first wants to finish his backup-script, in case anything goes wrong.
So that might take a while...

Maybe I can boot live Windows from an USB-stick?
You could probably install Windows from a USB drive onto an external USB drive, HDD, or SSD, but it would be slower than installing it on your computer itself. I don't know whether your dad would be that wild over you using Windows since he doesn't seem to like Microsoft that much from what you've said earlier. You could also boot a live Linux Distro from USB (The latest LTS version) and try running the latest version of WINE on it. You'd most likely want something more light-weight for live or external booting than Windows, but Arch with Xfce could work.
Yeah probably. I can try that.
I am now trying to boot Windows from an USB stick. But maybe an up-to-date Linux distribution with Wine might work too. I don't know which would be the better option.
I could try both.
Ok. So yes. I tried livebooting Fedora 34 and installing both Wine and Lutris.
Then I got it working.
So maybe if I get my father to install Lutris it will work via Lutris.
My laptop got upgraded to OpenSuse Leap 15.3!
Though when I tried installing Fer.al via Lutris it still did not work...
At some point I tried to see if using another Desktop Environment would work and actually that helped.
For some reason it worked in Cinnamon and Mate, but not in KDE, TWM and another.
Probably it needs a GNOME-based DE?
I don't really know. But for installing it in KDE it can still be done the more complicated way and then everything works too!
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum