Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
After trying three separate methods of copying from the temporary ASM execution program (Ztmp) back to the original program if changes were made, I finally got it working. I tried:

Delete archived original, then create 0-size RAM program with original name, move data from Ztmp, then delete Ztmp.
Modify VAT by swapping names for original and Ztmp, then delete Ztmp and rearchive original
Create temporary program for execution with same namelength as the original program. When writeback is necessary, delete original, rename temporary program by changing 1-8 bytes of the VAT, then archive. This method was sucessful.

However, several bugs that both members have reported and/or I have noticed myself may still be present, so this version will not be released on ticalc.org. Among said issues:

Program names do not appear under icons on second row
Scrolling bug Mk. III
The "Defragmenting..." / self-deletion bug may still exist

If you encounter any of these or other issues, please report them on the forum or the wiki. Without further ado, here's the new beta:

Download:
Doors CS 5.7 Beta 2
I shall give this a try in the next 2 days. Smile
Sweet. I was inspired to this while thinking about possible improvements for SC2. Smile
I am glad you are getting some of these bugs handled... Oh, and may I point you to the revsoft links page, and for you to check out your site's description? Wink
tifreak8x wrote:
I am glad you are getting some of these bugs handled... Oh, and may I point you to the revsoft links page, and for you to check out your site's description? Wink
Very Happy Excellent. Did you suggest that to them?
Actually, no. I merely pointed to two sites (yours and mine), pointed out Omnimaga's url changed, and that there were 2 defunct sites listed. He did the descriptions for both our sites. I thought them to be really good. Smile
tifreak8x wrote:
Actually, no. I merely pointed to two sites (yours and mine), pointed out Omnimaga's url changed, and that there were 2 defunct sites listed. He did the descriptions for both our sites. I thought them to be really good. Smile
Can't argue with you on that. I hope people can give me some details on these issues so I can solve them...
yay Kerm, you are on a roll.
elfprince13 wrote:
yay Kerm, you are on a roll.
Tonight I want to get the first mouse acceleration / speed thing working.
awesome, keep it up.
Initially I made 1 pixel per cycle of movement the minimum, but now I decided I'm going to rework it to have 1 px/cycle be the maximum. In slower modes, it will skip move cycles so that when you first press, it will move qutie slowly and gradually accelerate to full speed. This should allow more precise positioning on the tiny screen.
Sounds like a plan...

I made an attempt to look at the newest beta, will not load for me on PTI, runnin os version 1.19...
tifreak8x wrote:
Sounds like a plan...

I made an attempt to look at the newest beta, will not load for me on PTI, runnin os version 1.19...
I had no problem loading it under 1.19. WTF is wrong with PTI that you people are never able to load it?? Shock
I decided to test out some Ion/Mirage programs, and guess what? NO ERR: LINK! Very Happy This may just be on my calc, though...
calc84maniac wrote:
I decided to test out some Ion/Mirage programs, and guess what? NO ERR: LINK! Very Happy This may just be on my calc, though...
Yeah, I believe I may have fixed that and a few other problems. I need some more confirmation before declaring the bug solved though. What about the other bugs I mentioned?
I have never gotten "Defragmenting...", and the new scroll bug still exists.
The only way that I get names on only the top row is if I make a folder then sort the progs so it's at the beginning.
Can you tell me in exactly what form the scroll bug manifests itself?
(Taken from Doors CS 5.7 Beta 1)
calc84maniac wrote:
Okay, I have (almost) the same problem as foamy3. It only shows the names of the progs in the top row. When I scroll down it is still in the As, but when I scroll up it is in the B's and I can't scroll up any more.

Update: I deleted my one folder and it now displays right, but when I scroll down then up, it is suddenly in he M's (instead of the B's), and when I scroll down and up again, it is in the E's. (Another scroll bug perhaps?)
OK, so the bug is still manifesting itself the same way. Let me see what I can figure out with it.
Come to think of it, now it only happens when I scroll way down near the bottom and start going back up. It doesn't happen near the top anymore.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement