Official release just submitted to the archives w/ Mateo listed as a co-author.

I've also posted the release on github here

Thank you all for the feedback. I'll edit the top post once the archive submission is approved Smile
Thanks. Smile

Which custom game packs did you test ?
Because I'm sorry but something seems wrong with their support...

I tried 14 of them, and only 2-3 did work.

Working :


Most of them just immediately terminate the app :



Oiram Micro Levels can be launched once but not twice in a row, just terminating the app then.

Others are crashing the app and the OS as soon as you launch it, you can't even reach the main menu :


Super Mario Bros: The Lost Levels Remake Speedrun is listed as a blank entry and removed from the list as soon as you select it.
Oh man, I tested like 4 different ones that I grabbed off TI Planet. Don't remember their names off the top of my head but it must have been just good luck. I'll check this out in the next day or two and figure it out and get an updated version out
Fixed now critor, thank you. New release here
For me exited [0], press Menu crashed screen only appeared when i press menu out of the gameplay twice, and then went back into oiram from main menu, in terms of levels I downloaded quite a few (to minimise fiddling with my faulty usb cable) and played many times perhaps 4 levels and perhaps through luck each played well. By the way currently i only have access to fx-cg50 - maybe compatibility of levels differs by model. Which one are you testing on @critor?

There is one issue with button presses which may be not possible to fix but i will describe it separately after testing your new build, @tsw. Thank you again
rI have tried the new version and it always starts the same level for me so I could not test different levels - the only thing I noticed at around 29-30 levels the list of levels loads but any more levels (i'm not sure if it is the amount of levels or the total memory they take) and the CG50 reboots.

With the old version I can play many levels but the following are crashing:

SuperMarmOdysseyIntroCap,
SuperMarmWorld6 (but 1 to 5 play),
Illusions,
Wow levels

I downloaded all the levels but initially loading more than 20 would crash the add-in - so I started adding them in order of size and eventually managed to open the add-in with out a crash (maybe the add-in has self healing feature Wink or maybe something else happened randomly) but it appears quite slow scrolling from one level to another.

I wish I could use 'del' button to delete levels from the list directly (perhaps some broken level or once it was completed - it is quite hard to pick the file through memory app as level names and file names don't appear the same.

Also ac/on or more precisely off button would be nice to have working for switching the calculator off and on. I realize 'shift' if mapped to something else besides pause could be additional challenge for the off button but can imagine there are other issues with this too.

Finally button detection is somewhat buggy with continuous button presses - for example if I decide to use two rows of buttons for mapping key let's say '1' for jump/attack, '0' below it for run, 'exe' for right, and '-' above 'exe' for duck, I think the column row matrix gets confused so if i keep holding run and right and then do jump I get duck too... so many combos of of 1 and 0 with exe give '-' button press, in fact even holding '2' and '.' or similar combos in the bottom two rows then pressing 'exe' gives '-' button press.

Thanks again
Thanks for the thorough test Amazonka! I completely screwed up that last version but fixed your ability to level select with the new release:

https://github.com/tswilliamson/oiram/releases

Will update the Cemetech / TI-Planet archives as well. Cheers!
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 2 of 2
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement