I have a TI-82 and a silverlink cable that I am trying to connect to my Linux computer. However, TiLP doesn't seem to recognize the calc or any of my other TI-82's (i have 3). My cable is not faulty as I've used it with no problem for my TI-83+ calculators.

I manually selected the silverlink and TI-82 options in the menu, and then put my calc into receiving mode and selected the option to send to non-silent calculators. (I'm trying to send the Crash shell). The calc just got stuck on the Waiting... screen and there is no indication on the computer that it is sending anything or even recognizing the calc.

I have also tried the same thing but just with leaving the calc at the home screen, it didn't work either.

Edit: Sorry this posted twice by accident, i deleted the previous duplicate post
Can you try using an 83+ and the auto detect features to have TiLP II find the calc and the cable and then switch the calc to the 82. Its been a while since I looked at the code but the autodetect might be needed to get TiLP to see the cable properly.
I tried just now, it didn't work.
One thing I can add is it definitely needs to be in receiving mode because that is how non-silent link calculators work.

As for why it isn't working I might be able to pull out my 82, silverlink and Linux laptop to look after work if someone else doesn't have suggestions before then.
You've already ruled out multiple potential root causes for the behaviour you're seeing, by the fact that the same setup can communicate with a 83+ properly.
I figured it out! Turns out you have to click restore to send the files, not "send files"!

And also, the Crash shell ended in .82B, not .82b, so tilp wasn't recognizing the file. I feel dumb haha
Indeed, backups are received through Backup and need to be sent using Restore Smile
Don't worry, you did your duty to try and fix the problem before making a forum post, and your description was much better than some bug reports I've seen over time.

Still, I'm glad that there's no issue on the libti*/tilp side. Although I try not to do it too often, I sometimes break the code while refactoring it - it's a fact that I do not test everything I modify Smile
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum