Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
Hi first post here,
I just recently purchased a TI-89 Titanium HW4 for the fun of things and have come across an issue. I cannot turn the calculator off, when I do it will turn back on immediately. It is running the latest OS, the entire body of the calculator is pristine with no stuck keys, and I have reset and also attempted removing the backup battery to no avail.

Does anyone have any other ideas on what I can do to fix this or am I out of luck?
Even though that's unlikely, make sure that there's no conducive thing stuck into the classic (2.5mm proprietary stereo jack) link port, or the USB link port, though the latter should only manage to wake the calculator if it's connected to an actual USB host.
I tried the keys on my TI 89 Titanium. When I press on a key, there’s a slight resistance, then the key goes in and makes contact. Try pressing some of the other keys to get a feeling of how the keys feel. Then turn the calculator off, press the 2nd key, then the ON key (OFF). Do both of the keys feel like the way the other keys feel. Just wondering if the ON key contact might be stuck in the closed position and it doesn’t have the slight resistance before going in and making contact.
Lionel Debroux wrote:
Even though that's unlikely, make sure that there's no conducive thing stuck into the classic (2.5mm proprietary stereo jack) link port, or the USB link port, though the latter should only manage to wake the calculator if it's connected to an actual USB host.

I checked the ports and they are all clear, I will connect the calculator later just to check things out.

dave1707 wrote:
I tried the keys on my TI 89 Titanium. When I press on a key, there’s a slight resistance, then the key goes in and makes contact. Try pressing some of the other keys to get a feeling of how the keys feel. Then turn the calculator off, press the 2nd key, then the ON key (OFF). Do both of the keys feel like the way the other keys feel. Just wondering if the ON key contact might be stuck in the closed position and it doesn’t have the slight resistance before going in and making contact.

I tested all of the keys and they are all fine, I feel a slight resistance with even the on key and am still unsure why this issue is persisting. For the meantime, I am attempting to discuss it with the seller and in any case, perhaps opening the unit will be an option.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement