Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
I've been working on a program in ICE and I want to add an icon and a description for Cesium. I know how to do this, but when I add them the program stops functioning after displaying some random chars.
The icon and description are visible in Cesium however, so the syntax is correct, but they are pointless if you apply them to a program that doesn't work properly. This is the beginning of my program:

Code:
[i]SOLITICE
[i]"F0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0FF0F0F0F0F0F0F0F00F0F0F0F0F0F0F0F"
[i]Solitaire for CE
Begin
...


Does anyone know why this happens, and if so, how to solve it?
Did your program work before you added the icon?
Yes, perfectly.
Try updating ICE, or ask PT_ how to build the latest version off of GitHub, if you don't know how to already. The icon thing is an ICE issue, and either the current version has that issue, or an older version that you might be using has that issue. If updating to the latest version doesn't work, then poke (or nag) PT_
Redownload old version of clibraries. Had the same problem when I had to update clibs for HDPic thingy. You should probably keep two folders with old version and new version.

Edit: I just read the actual thread... this might not help (but hopefully it does)
Calcuon wrote:
Redownload old version of clibraries. Had the same problem when I had to update clibs for HDPic thingy. You should probably keep two folders with old version and new version.

Edit: I just read the actual thread... this might not help (but hopefully it does)

Is my program not working? It should work with the latest libraries, that's what I've developed it, and run it on. Could you please post exactly what's going on in the HD picture thread? Smile

To contribute to this thread, I've also had an issue with including icons in ICE programs, except the program wouldn't compile at all, it said "invalid expression". When I clicked 'goto' it took me to the middle of the icon data. I haven't had time to debug it so maybe I did something wrong just that once.
2 weeks later and I solved it!
I downloaded ICE Compiler 2.3.0.0 from https://github.com/PeterTillema/ICE and then I built it manually. I don't know for sure if this version is completely stable (ask PT_) but it managed to create the icon and description AND it got the program running, so this kerfuffle is solved. Good Idea
Newer versions of ICE are getting quite stable. I wouldn't say it is perfect, but for the most part, the wonky and fatal bugs have been hammered out. I wouldn't be surprised if this was something PT_ intentionally looked into and fixed, rather than the bug just inexplicably fixing itself.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement