I tried using onblock for my 84 plus CE. It will not work.
May help if you read the program thread. Wink
How does that help. I already did. IT does not work.
The thread says exactly that it wont, and can't work. The OS was changed making the program completely useless for new OSes. You'll have to downgrade your OS to below (I think) OS 5.2 if you want it to work.
There's no way to fix the program for the most recent OS.

EDIT: Well I'm mostly correct, I missed the part about GetKey messing up OnBlock.
Mateo wrote:
I would just like to point out that with TI being cool and updating OSes, OnBlock for the CE no longer works if you use any sort of getkey routine. Sorry about that Razz
FYI, ONBLOCK doesn't block the on button when you just run it. 1 has to be in Ans. You can either execute "1", then ONBLOCK, or 1:Asm(prgmONBLOCK or 1:prgmONBLOCK if you have OS 5.3 or later.
Hope this helps! (To disable, just run it again, but with 0 in Ans.
I tried doing that but is does not work. @jcgter777
Okay. Apparently, it's broken in newer OS versions. Sorry Sad.
But I have games that do not break when I click on.
Are you sure they aren't asm programs? Those don't break when you press on.
Oh they don't. Really. Yes they are.
Well all except Mario.
Then I don't know what's wrong.
PRO TIP: Use the edit button on your post, instead of double posting. Double posting within 24 hours is generally looked down upon.
Oh sorry. Good do know. So asm programs do not break. So I could create a asm password program?
Cesium (in the CE archives under asm/shells) has a password ability. It's also very nice. Be sure to read its ReadMe!
How do you set a password @jcgter777
Read the readme.txt included with the download, it'll tell you all you need to know. Wink
I did. However the shortcuts do not work. @thelastmillennial
Just fyi, @ mentions don't do anything on this forum.

The shortcuts aren't working probably because you never activated them. Like the readme says, press [mode] while on the Cesium main screen. Then turn on 'enable keypad shortcuts'.
And sorry of those <kbd></kbd>'s get in the way. Those were my ideas Razz. They look better on GitHub though.
Last Millennial. I did enable the shortcuts. They do not work.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum