Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
Hey, I recently downloaded the ICE Compiler onto my calculator. In the .zip file, after extracted, there's a "documentation.html" file. Open that and scroll down to the "Creating tilemaps" section, and there's two links https://github.com/mateoconlechuga/convpng/releases/tag/v7.0 and https://github.com/mateoconlechuga/convtile/release/latest (in the file as "ConvPNG and ConvTile"). When I went to the second one, I got error 404. Can anyone provide a link to a download for ConvTile?
No. First of all, the convpng link is outdated. You should be using these two urls:


Help this helps Smile
So, I created a folder and put in my tileset.png, tileset.tmx, tileset.tsx, and tileset.csv , as well as convtile.exe and convpng.exe. The documentation for ICE says "Open Command Prompt, navigate to the folder, and run convtile --ice" but when I do, it says "convtile: Command not found." Any ideas?
You didn't navigate to the correct folder.
I did, and I double checked like seven times. Maybe it's because I'm running linux and using wine to do stuff with the .exe files.
Why on earth are you using wine when there are linux builds of the files provided.
Okay, I put the linux versions in the folder and got the same result.
Then you don't know how to use Linux:

19:30 <MateoC> Don't forget:
19:30 <MateoC> chmod +x convpng
19:30 <MateoC> ./convpng

19:30 <MateoC> Don't forget:
19:30 <MateoC> chmod +x convtile
19:30 <MateoC> ./convtile

You need ./
Okay, the problem is with me; I tend to overstate how "smart" I really am, and as a result, I tend to step into territory that I'm not ready for. The problem is 100% me, not at all you.

But hey, it worked.
One last thing, and I feel like an idiot saying this, I made convpng.ini with the correct text, but how does one run convpng on linux?


Don't feel like an idiot, we all learn something new every day. Razz
Okay, the version of "GLIBC_2.27 not found," where would I get that?

I just found out my computer can't get that, and what it has is the best it knows how to do. So I'm gonna have to do this at school where they have better computers. Hmf... Mad

Edit 2:
Nvm, problem resolved. I tested the windows version and it worked perfectly. Now I have the TILES.8xv file! Very Happy
Quick question, what's the "TYPE_HEIGHT" and "TYPE_WIDTH" arguments in "DefineTilemap("?

Edit: If I had a 2x2 tilemap with 8x8 sprites (that I want to be displayed twice the sise) in an appvar called TILES that is 14 bytes, to define that tilemap in ICE, would I use:

Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum