Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
Today, I was using my calc (Ti 83 Plus) in the car. The car was about 60-70 Degrees Fahrenheit. I was playing a Tetris clone in pure basic. I noticed one column of pixels go out, so I immediately closed the game back to the basic / asm launcher I made and the whole screen was slightly broken. Random sets of pixels were missing, but the column that had disappeared was back. I thought it could be from the heat, so I cooled it down some. I also Archived everything, GarbageCollected, and cleared the RAM. Still broken.
When I got home I tried the power drain method. I took out all of the batteries, including the backup, and let it sit on its face for a while (A few hours). Put the main batteries in, and it was fixed!... For a whole five minutes.
I was dreading taking it apart, but reluctantly did anyway. I took the back off and moved the RF shield. Then I took a look at the ribbon cable. It looked OK like I expected it to. I then took a multimeter and checked the resistance from each side of the cable. It took a while because I could only access the pad on the screen side of the cable, so I needed to trace the trace to the nearest metal piece on the main-board side. And... all the resistances were 0. (Except for the two pads that are not connected to any traces.)
I snapped the bottom half of the calc back together so that the batteries could connect, put them in, and turned it on. I was greeted by a bunch of random pixels all over the screen, but only for a second. Then there was the standard "RAM Cleared" screen. The column was still missing. I opened the MEM menu, and the column came back. Pressed clear, and the column did not disappear. The screen is working 100% now. However, it is probably going to quit on me again.
Should probably mention this. A few years ago, the calc had the same problem. Garbled stuff on the screen, missing lines, missing pixels, etc. My Sister "Fixed" it by hitting it until it worked. I did not question it.
I guess I will try my best to explain what exactly the garbled mess it. I know nothing about LCDs or the core system of the TI 83, but I think the problem is the D/I pin. When I open the Mem Mgmt/Del menu, it all looks fine. When I start scrolling, the bottom line always looks fine. However, the other stuff falls apart. However, if a program name loses part of a character, and then I scroll, that specific part of the character remains gone. This makes me think that the screen is getting Picture input mixed up with command input, hence the D/I pin.
I am looking for any input on a fix. Thanks in advance, JustSomeDude
When they show up, are the missing lines of pixels completely blank or are the pixel outlines still visible? If the missing lines are completely blank, it might be the upper ribbon cable failing, which is near impossible to fix with household equipment.

If you have the graph link cable, you could also try reinstalling the OS which you can get from TI's website.
I think they are completely blank when they turn off, but I did not get a good look. I do not have a link cable.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement