My TI-83 Plus will not connect to my computer. Whenever I click any option in TI Connect that tries to connect to the TI-83 Plus, it opens the connection window with USB, COM1, COM2, etc. It detects my TI-83 Plus just fine, but upon clicking on the USB section, Refresh, or Select, the window stops responding and never recovers. I've tried uninstalling TI-Connect, resetting my calculator, using all the usb ports, using a USB hub. When I look at the Device Manager, I'm told that it should list the TI-83 Plus as a TI Education Device, but mine is listed as "Texas Instruments SilverLink (USB GraphLink) Cable". I'm using Windows if it helps.
Welcome to Cemetech! Try doing LINK>Receive... while plugging in the calculator, starting TI-Connect, and doing anything that connects to the calculator. Alternatively, try another cable.
oldmud0 wrote:
Welcome to Cemetech! Try doing LINK>Receive... while plugging in the calculator, starting TI-Connect, and doing anything that connects to the calculator. Alternatively, try another cable.

I did what you said, and it still froze. I also eventually got this error on the TI-83, "Error in Xmit" if that helps. And I hope I don't have to bu another cable because USPS sucks at getting packages here on time.
Thanks so much for your help.
Hmm... Try TiLP? It's the open-source version of TI-Connect. http://www.ticalc.org/pub/win/link/tilp.zip
oldmud0 wrote:
Hmm... Try TiLP? It's the open-source version of TI-Connect. http://www.ticalc.org/pub/win/link/tilp.zip
I installed it, but whenever I try to open it, I get like 5 errors that look like this. http://prntscr.com/ebdxqq
I have had a similar problem with my CE
Do you have any programs? (I was told that some programs can be corrupted and mess up TI Connect)
Can you try using another computer?
Or reinstalling your OS from someone else's calculator. (I would get conformation from more experience users on this site before proceeding with that)
Good luck!
TheLastMillennial wrote:
I have had a similar problem with my CE
Do you have any programs? (I was told that some programs can be corrupted and mess up TI Connect)
Can you try using another computer?
Or reinstalling your OS from someone else's calculator. (I would get conformation from more experience users on this site before proceeding with that)
Good luck!

1. No, I cleared the entire calculator
2. I could, but it would be a day or two before I can
3. I don't have the cable (If there is one) to do that.
Oh, shoot. Sad
I don't know anymore advice I could give. Hopefully more experienced people can help you.
Good luck.
You could try reinstalling the driver in Device Manager, or completely reinstalling the TIConnect software. The calculator should not be in "Receive" mode when it is connected to the computer. Trying a different USB port may also help, if you haven't tried that already

I'm not sure, but it may help to plug the calculator in to the computer before starting the TI Connect application. I'd also try installing fresh batteries.
*major necro-bump

Hey dude, I recently had this same exact issue (I'm on windows 10. 64-bit computer). I found this to be the solution:

1. Right Click the icon for the application (either the shortcut or the application itself will work) and select Properties.
2. In the pop-up window under the "compatibility mode", check the "Run this program in compatibility mode for:" and choose Windows 8.
3. Click Apply and hit OK.

Now it should work.

I know this forum thread is like three years old but just in case anyone has the same problem in the future Wink
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement