So, I decided I might as well try and enter the contest!

I have a plan for the game and how I will make (most of) it, just depends on whether or not I use my amazing procrastination skills or not Smile

The plan is to have an endless runner type game, where you play as a ninja and jump over train cars with obstacles on them and try not to fall off the cars and/or hit the obstacles.

"Ninja Train-ing!" Yeah!

Checklist of things to complete:
*Levels [0% ]
*Graphics Routines [50% ]
*Physics [0% ]
*Menus [0% ]
>Actively maintain a topic

Ok so I have a 'progress' update: Not much progress has been made. EXCEPT writing out some psuedocode in a Word document, and planning out the program a bit.

[--removed, no longer matters--]

EDIT: I wrote almost all of my [first] assembly subprogram for graphics today. I haven't actually tested it though; it might crash immediately, haha. Does anyone know how to dump a TI84+SE ROM on a Mac? I tried rom8x but it doesn't seem to work when I run the code supposed to 'pack' the rom.

I want to be able to test my program without crashing my calc over and over Smile
>>Actively maintain a topic

Progress Update #2: The ASM subprogram has been tested and debugged to the point where it isn't quite functional but stopped crashing immediately. Hurray!

It still needs work, but it's getting better, at least it can draw a few pixels in messed up strange order. Still trying to figure that one out...
If you are trying to ROM dump on mac you might check out this topic. I tried it as well and never could get it done due to my computers settings but it might help.
Kydapoot wrote:
If you are trying to ROM dump on mac you might check out this topic. I tried it as well and never could get it done due to my computers settings but it might help.

I'm pretty sure I don't have administrator access, so that may not work for me either, but I'll try it.

Better than crashing my calc over and over Razz
Soooo, I have made little progress recently due to a combination of holiday celebrations, lack of sleep, and visits to and from friends Smile

But, I finally got myself to come back today, and I am having an issue with my assembly program. My program is currently able to
▪ Get a character ID from debugString (which is just an $03 followed by 9 or ten nulls)
▪ Get the corresponding character data
▪ Display a garbled version to the screen

What it is NOT doing, however, is more important right now.
× Shifting the components of the bitmask into the proper locations.

I am using a SRL e followed by a CALL c,shiftLeft
which is supposed to SLA A four times to move it to the right spot for bitmasking. Only it isn't shifting...? I may be missing something obvious here but this is my current problem.

It still stopped crashing for now though, yay! Smile
Ok, I still can't seem to figure out why the CALL NC isn't working. The code used is simple:


;At this point, A holds (0000xxxx).
;HL holds the location within the graph buffer where the data needs to go.
;var_x is a label storing the x-variable, which is currently just $0000.
   LD DE,(var_x)
   SRL E
;If carry flag is RESET then jump to an extra shifting loop and SLA A four times.
   CALL NC,shiftExtraLeft
;Bitmask A into the graph buffer.
   OR (HL)
   LD (HL),A
;...more code here, skipped because size
   SLA A
   SLA A
   SLA A
   SLA A

Does anyone see some problem with this code or is my issue elsewhere...?
It displays the character data seemingly like it should except for the shifting. I do not know why this is.
I still don't understand why this isn't working, it loads from the same data every time from what I'm seeing and if the NC doesn't execute then C should at least...?

Also, I might not finish this by the contest, what should I do if this is the case? :\
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum