I happen to have access to several spark cores, and I was wondering if I could make a more "permanent" version of the breadboard layout that KermM did.

I was thinking of a housing and perfboard/chemical etched design that would end up looking like the Ti 84+ Orion.

Is it okay for us to remaster these projects that others have done?

Just asking out of courtesy.
Absolutely; the project is open-source. I just ask that you give credit where credit is due (and keep us appraised on the project's progress as you work on it!). Good luck.
I'm trying to build the Spark Core program for the Photon that I have, and I'm getting an error (as well as many warnings, but whatever) here:


main.o (symbol from plugin): In function `app_setup_and_loop':
(.text+0x0): multiple definition of `led_state'
gcnbridge.o (symbol from plugin):(.text+0x0): first defined here
src/main.cpp:98:13: error: type of 'led_state' does not match original declaration [-Werror]
gcnbridge.cpp:106:9: note: previously declared here
 uint8_t input_pending;
lto1: fatal error: errors during merging of translation units
lto1: all warnings being treated as errors
compilation terminated.
lto-wrapper: arm-none-eabi-g++ returned 1 exit status
/usr/local/gcc-arm-embedded-gcc-arm-none-eabi-4_8-2014q2-20140609-linux-tar-bz2/bin/../lib/gcc/arm-none-eabi/4.8.4/../../../../arm-none-eabi/bin/ld: lto-wrapper failed
collect2: error: ld returned 1 exit status
make[1]: *** [973a8a11d6ec7c47db2053238fbd3096cea2e081d665e871e6531eccd0b7.elf] Error 1
make: *** [main] Error 2
Error: Could not compile. Please review your code.
If you get this working with the Photon, please let me know! Very Happy I have everything set up but this firmware with the photon doesn't seem to work yet. I wish you the best of luck and less frustration than I had. Razz
How much is different than the Spark Core?
I'm not sure, Kerm said they should work the same... it could be really subtle though
I know its been more than a month, but I have great news!

I just tried flashing the spark firmware onto the photon particle, and it works!

I don't know what was different this time, but all I know is that I now have the wireless firmware on the Photon particle.

Unfortunately, I do not have my calculator here at work. I'll go home today for lunch and bring it back, and then I can verify if this works.

I also have an idea for stackable breakout "shields" for the Ti 84+. They'll be perf boards with specially placed headers and ports that will allow you to use:

-both the 2.5mm jack AND the usb port
-power from one or both ports?
-a battery shield
-the wireless shield
-a sound shield?
-the gps shield!

The idea is that I could make a serial thingy that would go from the usb port of the calculator to micro controller on the base shield that will then output i2c and spi (spi for board level, i2c for data?) using stacking pins to let you have up to 7 shields at once.

I'll add pictures of the wireless hopefully working later today.
I have to ask, is this a gCn over wireless related project??
Yes sir, this is such a project.
Sweet! I'm definitely following this project! If you can get it working, I'd either try to follow your procedure or buy one off you (assuming you make more than one). I've often imagined making a hub-like device that allows WiFi, wireless charging, audio out and stuff, but I don't possess the technical know-how to so something like that. Maybe I've given you an idea :p
How did you get the Photon working? How long did it take you? I tried for 4+ hours with no success. Was there a different firmware version you used? Did you change anything?

I tried to get the wifi working, but to no avail. The board flashed successfully, with the green light and everything. However, I must not have something hooked up right.

I'll post pictures here of it today (Definitely will, I really want this to work).

If anyone can help me out with the pinouts and the need for pullup or down resistors and the like, it would be much appreciated.

A curious note is that once I flash the firmware to the photon, I can no longer connect to it via the app on the phone, or even reflash it again without resetting the board. Its a minor nuisance, but I thought it was worth mentioning to see if its supposed to do that.


Its interesting, because I actually used the photon that we have here at work. I tried my photon from home first, but that didn't work. However, I think I was trying on a different firmware, so I have no idea.

I got it to compile using the most recent, 0.5.1 firmware. It could be completely luck, but it worked.
Update again!

So far, the Photon can be flashed with the 0.5.1 firmware, and the green light glows and dims as expected and shown in the existing videos. However, no network can be accessed yet. I will do more work in looking into the firmware and such before the next build.

As a thought, are there places where I can get a Spark Core? I searched eBay, and came up with results for Photon/Spark Core Compatible (as in its a Photon board). Any help in this department will be much appreciated!
I'm afraid I don't know of a place where you can buy a genuine Spark Core any more, and I bet some of the ones on eBay are cheap Chinese knockoffs, not even genuine Photons. Also, I think we all misunderstood you: I think we thought you got the firmware working on the Photon, not just loaded. Good luck debugging it; I wish I had the time to help you figure it out. Perhaps I'll have to set aside a few hours some weekend to take a stab at it.
I actually DID get the firmware working on it, I think the second flash I did it worked. However, after I reflashed the working one on my own Photon, it no longer worked. I have no idea why it would behave this way. I'm currently working on it now, using the first Photon it worked on.

Also, I did find one on eBay for cheap! It should be here soon!


Before anything, I really don't like being part of a huge project that a community follows and NO ONE knows what I look like.
This is the lovely face (that's a joke) of the one spearheading the port of gCn Spark Core to the Photon.

Believe it or not, I'm actually in a tree because my tech job had a special situation in which I needed to hike for an hour up a mountain to a cliff and take pictures. Pretty neat tech job, I like it alot.

Anyway, I finally got the firmware working consistently on a Photon, but it only works sort of. Here's what I mean:

My calculator isn't exactly stable (its using a trim pot to control the clock), so I've ordered a ti 84+ for cheap(ish) to use as a project calc. No modding, just software stuff. I will eventually get a Ti 84+/SE and use a digital trim pot (most likely via arduino pro/teensy 3.2 to an i2c trim pot) to achieve a much more consistent and stable clock.

I digress. The issue here is that the bridgeconfig program freezes, or hangs, really. The scrolling bar in the upper right corner keeps scrolling as usual after the yellow light blinks to life and then dies. However, no keypress/keypresses I do can break out of the program. Even holding [ON] didn't help. As of now, only a battery pull can reset the calculator. Again, this calculator is not really stable to begin with, and my coworker (the cameraman) doesn't trust me touching his calculators. I wonder why...

I hope this is a giant leap forward in the porting of gCn to the ti 84+/se calculators. I dream of a day where one can just slot in a wifi card to their calculator's I/O ports and then proceed to chat with the rest of the world, and even download any program they desire from ticalc.org. It will be a grand day.

Until then, I shall keep slaving away!

The Photon Particle is now a viable platform for wireless connectivity!

It turns out that it WAS my unstable calculator that was causing issues. I think a large part of it was timing issues, the baudrate being not exactly 9600 as it should be. Oh well, the overclocking potentiometer was a cool project too.

Here is some proof:

Now, how do I type in an underscore ( _ ) in bridgeconfig? I can't figure out the key combo to save my life.

I need it to type in the ssid. If I change the wifi ssid to not include such an underscore, I'd really p.o. my family because everything depends on the names staying the same.
This was long overdue!

I've used Eagle Cad to make this pcb, as well as using an inkjet printer with its transparencies to print the board. I used a positive photoresist method.

It even has my name on it so its official! Very Happy

I'll try populating it tomorrow. I think the drill I used (the smallest bit I had) is still too big. I'll go to the hardware store tomorrow and find one there thats the right size, and then redo this board.

What do you guys think?
Nice work so far! I agree that a slightly smaller drill would be a good idea; I'm worried about the quality of those connections with so little copper left around the holes. Keep up the good work.
Well, months later and finally the Spark Core is flashed correctly!

I can't work on this project as much as I want to, so please forgive the sporadic updates.

I was going to test out the new firmware today, but I managed to pretty much brick BOTH Ti 84+'s I have. They say "Install OS..." but they don't show on the computer.

I do have a few TI 83+'s that I don't touch, so I will give those a try.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 3
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum