Just trying to display something basic on SC3, and when run on the emulator this result is incomplete, BUT it works on the real calc.

Input "Enter DEGREES: ",D
Input "Enter MINUTES: ",M
Input "Enter SECONDS: ",S

D is 15
M is 27
S is 6.3

Answer SHOULD be 15.45175
When run on the emulator, it just shows "15"
When run on the REAL calc, it shows "15.45175"
Perhaps the mode in the emulator has been set differently than your calc?

Specifically the Float option shown here:

(it's on the B&W calcs too).
Nope, it was set to FLOAT. So weird. I just moved the equation to the Output line, and it worked. I dont understand that at all, but if it worked, it worked.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum