Hello,
Trying to help my daughter.
I've tried all the fixes I found on line and nothing has worked.
Replaced all batteries. Held Clear while removing and reinstalling a battery.
Taken out all batteries and let it sit for 30 minutes.

Still locked up. Cursor is solid in upper left and Screen shows TI-84 Plus
2.55 MP
Ram Cleared
Press Alph F1-F4 to locate shortcut menus

only key that changes anything is the on button but that just removes all the text and leaves a solid block in the upper left corner.

I've tried connecting it to my mac and downloaded the TI-Connect app but it doesn't see the calculator.

Any help would be appreciated.

Thanks
I've also tried the Del / remove battery / reinstall battery

This calc is only 1 yr old. No moisture or battery compartment issues. It's pristine.
Hmm...
I'm not much of a resource, but did you remove the backup battery underneath the battery cover? (You need a screwdriver to remove it)
Are the batteries good batteries? Sometimes low batteries will cause weird problems.

Also, it's best to use the edit button instead of posting twice in a row.
Yep removed the LR44 battery and installed a brand new one.
Also installed brand new AAA batteries multiple time to ensure they were all good.
It sounds like either you have a stuck key or something is in your link port. Is anything jammed into the round port at the top of the calculator? Also make sure that no keys are stuck. Was anything sugary or liquid spilled on the calculator recently?
No the calculator is clean. Never had anything on it or it. The ports are clear. I've done what I call a keyboard smash....trying to clear any keys that may be stuck. The only key that responds is the on/off key..but once pushed the first time it won't do anything else. Then the screen just has one black solid block in the upper left.
Alright...I don't know which one of you telepathically fixed it, but it finally came back to it's senses and is working.

Thank you guys for responding.
Third Wave wrote:
Alright...I don't know which one of you telepathically fixed it, but it finally came back to it's senses and is working.

Thank you guys for responding.
Our pleasure! If you have any further questions, we're more than happy to help. I'll insert a quick advertisement for "Using the TI-83 Plus/TI-84 Plus" if your daughter needs any help with the calculator for science, math, or the SATs, and isn't keen on using forums.
Much appreciated.
Ok, since I have exactly the same problem as Johnny (OP), ...spent a few hours on the web searching for an answer and nothing has helped to bring it back to life again…, let me put your telepathic ability to a test one more time then, please. It worked for Johnny it might as well for me. It looks like this is my last hope.
I will report the results later. Thank you.
Cheers!
Just to cover the bases, I'm assuming you've followed advice in this thread?

  1. Check for stuck keys
  2. Made sure the link port is clean
  3. Replaced with fresh/new batteries
  4. Hold Del, Remove Battery, then Reinsert battery
5. Hold Clear, remove and reinsert battery
6. Remove batteries, hold ON for 10 sec., reinsert batteries
7. Remove all 5 batteries, wait for a few hrs, reinsert

…yes, all covered. No avail.

Thanks for the quick reply.
An update:
so, after sitting on my desk for a few months and just before scrapping it, I decided to reinstall the battery one last time and turn it on, just for a heck of it and voila! it came back from the dead.

If the calculator dies on you, do not throw it away. Wait! It can resurrect at any time, just be patient.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement