I posted this because even following the tutorials i donīt know if im doing something wrong

Mad

I tried to downgrade my NSpire CX from 3.6 to 3.2 CAS, and failed hard *.* now i have a USB Adapter and im using a frecn tutorial.
When i use the hyperterminal the first time that i put the batery i recieved this message

Quote:
Boot Loader Stage 1 (3.00.99)
Build: 2010/9/9, 17:29:13
Copyright (c) 2006-2010 Texas Instruments Incorporated
Using production keys

Last boot progress: 65

Available system memory: 33196
Checking for NAND: NAND Flash ID: Generic 1 GBit (0xA1)
SDRAM size: 64 MB
Turning device off


expected as the manual say but i couldnīt put the boot2, i tried again but now when i put the battery the calc, turn on inmediatly and it show the system error in the screen



meanwhile it show this code in the hyperterminal

Quote:
Boot Loader Stage 1 (3.00.99)
Build: 2010/9/9, 17:29:13
Copyright (c) 2006-2010 Texas Instruments Incorporated
Using production keys

Last boot progress: 65

Available system memory: 33196
Checking for NAND: NAND Flash ID: Generic 1 GBit (0xA1)
SDRAM size: 64 MB
SDRAM memory test: Pass
Clearing SDRAM...Done.
Clocks: CPU = 132MHz AHB = 66MHz APB = 33MHz
Clearing SDRAM...Done.
Clearing SDRAM...Done.
Boot option: Normal

Loading BOOT2 software...

99%
BOOT1: loading complete (307 ticks), launching image.



Boot Loader Stage 2 (3.10.16)
Build: 2011/7/6, 14:38:40
Copyright (c) 2006-2010 Texas Instruments Incorporated
Using production keys

Clocks: CPU = 132MHz AHB = 66MHz APB = 33MHz
Checking for NAND: NAND Flash ID: Generic 1 GBit (0xA1)


Initializing graphics subsystem.
Boot option: Normal


Initializing filesystem.
Datalight Reliance v2.10.1150
Copyright (c) 2003-2006 Datalight, Inc.
Datalight FlashFX Pro v3.00 Build 1358
Nucleus Edition for ARM9
Copyright (c) 1993-2006 Datalight, Inc.
Patents: US#5860082, US#6260156.
BOOT2 Error: posix_file_init() error


i really tried to find the mistakes everywhere some says that i just need other version of boot2, the question is that im trying but the hyperterminal donīt show a sign that is sending the archive, i donīt know if i need to do something more, im following this tutorial in french with google translate http://tiplanet.org/forum/archives_voir.php?id=3507 im in the part of send the boot2 to the calc, the USB adapter worked and recognize the calc, if someone can help me i will really appreciate it.
Just to be clear on what you did: what HW revision is your calc ?
It's the last character of the serial number on the back.

Over time, we've seen TI-Planet tutorial being "copy-pasted", and badly, as they removed crucial warning parts (for example, big red bold statements saying that revision J or later will not be compatible, and there are bricking possibilities).

If indeed you have a J+ HW Rev and you have a boot2 3.1, then you can't do anything about it on pure software indeed - go thank the people who badly copied stuff...
And yeah, maybe rs232 sending, I actually don't remember if that applies here, I'd guess so.

One more thing : are you able to go to the maintenance menu (if so, select option 2 and/or 4, then reinstall a proper OS)


Edit : similar topic here, in English too: https://tiplanet.org/forum/viewtopic.php?p=170198#p170198
well is P-05140
With an O hardware revision, boot2 3.1.0.16 (calculator-side real version number 3.10.16) won't work for you. Your calculator won't run anything older than OS 3.6.0.546.
You need to use boot2 3.2.4.7 (3.24.7), which is embedded into the official Nspire CX image for OS 3.6.0.546/550, and can be extracted by simply unzipping the .tco file.
it didnīt worked, i canīt sent the image but thanks for the help anyway
So you can't send boot2.img through the RS232 TTL port ?
well after i charged the battery no show me a different screen but the same results Mad





and it never pass the 0
The RS232 output makes it clear that the device is shutting down before you have a chance of sending any data to it, because there's a problem with the power supply.

What if you remove the battery entirely, leaving the calculator powered through the sole USB A <-> mini-B cable ?
well it didn't turn off, but i still canīt send the img, when it turn on, the system error appears at the same time that i see that line of BOOT2 in hyperterminal
That's better Smile
Now you need to put your Nspire CX in boot2 receive mode through the appropriate key combo listed in the Nspire series maintenance key combo reference: https://tiplanet.org/forum/viewtopic.php?f=15&t=5360&lang=en

For best results with boot1 key combos, it's best to press the keys before putting the power back, and leave them held (pressed) for several seconds. When the terminal output indicates that the Nspire is ready to receive the boot2 image, you can send it.

The diags software is the best way to charge the calculator through the USB port. If even charging the battery for several hours inside the diags software, the battery is still at a critical level... it's likely that it's defective, and reaching out to customer support / service will be in order.
YEEEEEEEEEEES now i could manage to send the boot2 and it works again, i was missing the key combos step, THX! FOR YOUR HELP i was really close to destroy this īī brick īī xD Good Idea Good Idea
You're welcome Smile
Now you need to deal with your rechargeable battery's behaviour.

Cemetech is far more oriented towards the TI-Z80 series than towards the TI-Nspire series, BTW.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement