I was playing Pokemon Topaze, but my RAM crashed. It messed up the appvars, and also, more importantly, the calc returns a ROM FAIL message when I run the Diagnostics Test (MODE->S). What should I do? I've considered a full wipe, but I want that to be a last resort. RAM clears do nothing, as I expected, and the other apps still work. How can this be fixed?
I had this same issue a while back, and I found that even a full reset doesn't work. You have to actually re install the entire OS, but if anyone else has found a better way, please share. Thanks! Smile
I don't know how to fix that really, but what I would do is make a backup of the calculator when transferring files to it. That way, if a poorly-written program or some conflicts with hooks disrupts your calculator, you can just restore the backup. You might have to reinstall the OS first, though...
As I mentioned in IRC, I've triggered the ROM FAIL message before simply through crashing assembly code, and I've often seen the ROM FAIL message from the MODE-ALPHA-S self-test. Does your calculator actually seem to be having problems, or is that message in the self-test the only issue? If you're in fact having stability problems, I agree with Mateo that you should re-install the OS.
Well, I have had some issues that re-installing the OS doesn't seem to fix, either... Sometimes I can't access my Table because it is "Archived", my option to plots on from Y= isn't there (it displays on the graph screen), my list editor doesn't display anything... Weird stuff.
*super necropost*
Yup, installing OS 1.19 worked. Those people up there (↑↑) were right again!
GTemples27 wrote:
*super necropost*
Yup, installing OS 1.19 worked. Those people up there (↑↑) were right again!
Glad to hear that it worked (almost a year later), and thanks for confirming the fix so that other people with the same issue will be able to come to this topic and find verification that this will fix it for them as well.
Resend os if there is rom fail. This was suggested to me by hightechcomputergeek and it work on my ti84+se that was majorly fussing. Everything can be fix on ti calcs... Dont worry...
Ummm... dude. This was posted (originally) 1.5 years ago, and I posted my solution (well, not MY solution, but the fix) 6 months ago.
Forgive me for being blunt, but read the thread next time.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum