I'm trying to assemble the sample program decode7.asm.
I have purposely removed the decode7.8xp from the exec folder so I can test the assembler.
I'm on Linux so I ran ./compile.sh decode7.
The aasembler spits out message that the source file was found and that it is assembling.
The problem is that at the end of the process there is no executable in the exec folder.
I have checked permissions for the folder.

Could you please share some more information about the issue? Specifically, could you include the exact error message that's being produced, as well as the list of files in the relevant folder?
Absolutely. the error was that I can't read!
The name of the sample file was docde7.asm but I tried to compile "decode7.asm"
Found the problem and it now works.
I would have been helpful though if the shell script would have output a message saying source file not found or something like that.

Thanks and sorry
Let me know if you have any questions about Document DE! It's been a while since I've touched the source code, but I have a cold cache somewhere in the back of my mind.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum