EDIT/Update:
I was about to make a $4 Serial Link cable and try that when I realized that I can send the OS from the Voyage 200 to the 92+ over the calculator to calculator link cable.

TI Connect /Silverlink Cable/Windows 10 does not recognize my TI92+ nor my Voyage 200: I have conflicting info on whether it will or won't work. I am led to believe it doesn't as:
I know the software/driver/cable work because it works fine with my 83+SE, 84+SE, and nSpire with 84 keyboard.
And, I know that the Voyage and 92+ comms work because I can cable them to my 89 Ti and they work with that.
So, my thought is to go with a Black or Gray cable on an older machine that I have that has a serial port. I really want to upgrade the OS on my 92+.
Does anyone know what combo of software/cable works with the Voyage/92+?


-TRS80
Too bad I didn't see this topic earlier.
* nope, you can't send the OS from the V200 to the 92+.
* yup, TI-Connect / SilverLink / Win10 definitely ought to handle both your 92+ and your V200.
Was about to edit my post that transferring the OS only works between like models, this is documented by TI.
I'll keep at it with the Silverlink then...
Maybe you could force the calculator into OS receive mode by entering the boot code (pull a battery, maintain APPS pressed while you put it back on and press ON) and pressing i ?
But before that, if you want to back up the calculator's contents without going through another calculator, TI-Connect (or TILP) needs to work.
I did try that. No good. And I tried on a different computer, no luck there either. I'm going to try the 4$ serial link cable route, it took me a bit to hunt the parts down in my electronics parts stash.
Most modern computers don't have a real RS232 DB9 port, and the BlackLink / $4 cable requires access to low-level bit-banging, a capability not exposed by most USB / RS232 adapters.
A GrayLink (or one of the third-party reimplementations thereof, which have their own quirks) might be less hassle.
That's exactly why I keep a few 1990's IBM Thinkpads and their docking stations around - for their real serial and parallel ports Smile. I have a parallel EPROM programmer that doesn't like USB adapters. I'll keep an eye out for a GrayLink cable though.
I believe with the latest patches to the libraries used by TILP I believe the blacklink should work with nicer USB serial adapters at least it did when I did my testing. I'm not sure if those patches I made ever got up-streamed as it was a pretty niche of a niche use case. The main goal of those changes were to make it use COM1-4 rather than hard coded hardware addresses the older code used if I recall correctly.
Well, nope, I never upstreamed your patch because I was not really able to test it for both hardware and software reasons, and I spent more time on other things which were less of a niche use case (though admittedly, the semi-recent lab equipment stuff is also a niche use case...).

Only several weeks ago, for other purposes, I gained a Windows 10 license, and I happened to install it onto a desktop computer whose 10+-year-old MB provides a native DB9 RS232 port, I've checked. [EDIT the next day: eh, nope, it's in another computer I also installed recently - I need to swap the header] But I have no BlackLink, and no known working $4 cable. ISTR that there's one in Romain's stuff, but at least one of the wires looked in a bad shape. Of course, that could be fixed.
Lionel, I can send you a black link if it will help?
I'd better test the $4 cable first, because the delivery's going to be expensive. Thanks for the offer, though Smile
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement