A friend of mine just recently got a CASIO Fx-CG50. This friend has previously been making programs that have been uploaded to Cemetech and would like to continue to do that using his CASIO calculator. While looking through the archives I noticed that there is a section labeled "Casio Prizm (fx-CG10/fx-CG20)", but nothing labeled Casio Prizm (fx-CG50). If my friend were to make a program using his Casio Prizm 50, then could it be uploaded to the Casio Prizm (fx-CG10/fx-CG20) archive folder? Is there a significant difference between the two calculators?
Anyone's help would be greatly appreciated.
RoccoLox Programs,

I, just like your friend, am extremely interested in Casio-Basic. I myself have a Casio FX-CG50 and unlike any other of my 9 calculators I would rate it a solid 9.5. This "Prizm" calculator is (kind of) new and was released in (I think.. 2012 or 2013?) I have published a couple of Casio Programs under the Casio Prizm (fx-CG10/fx-CG20). All these calculators are Prizm calculators, mostly all of the programs under this category will work with a FX CG50 because it is a Prizm calculator. Nothing would change (except for a slight decrease or increase of speed depending on the file size). Your friend is good to go Smile.

Bipolar Sheep
To answer the question you didn't ask, there's no particular reason that it's labelled as "fx-CG10/fx-CG20" except perhaps because the CG50 didn't exist when that was set up.

I've changed the label on /prizm and its subcategories to avoid referring to any particular variant of the Prizm now.
Thank you very much Tari and Bipolar Sheep.
Hello I have just purchased a casio CG-50 and installed C.Basic 1.45 and i have found the load command will only read in 4096 bytes maximum, is there a way to fix this, i have tried to contact sentaro21 without success.
Smiling Cat
Maybe this is the wrong place to answer but nervermind.
C.Basic isn't maintained by Sentaro21, as he unfortunately seems to starts doing other personal stuff...
For the Load() command, I can't reproduce the bug... I loaded a bmp into a matrix, saved the matrix in a binary file (472320 bytes) and loaded the file : it worked fine...
Good luck Smile
Thankyou. I will try that.
Smiling Cat
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum