I have SourceCoder 3 running on my iPad. I’m trying to run a simple asm program, but it’s not doing what I think it should. I’m expecting the numbers 123456 to show on the display, but only the number 1 is showing in the middle of the top row. Here’s a picture of the code and what’s displayed. Am I doing something wrong or is it SourceCoder 3 on the iPad. I’m on ipadOS 13.3 .

PS. Moved to SourceCoder discussion.

This is not an issue with SourceCoder (although SourceCoder is kind of broken right now), it is an issue with the code.
Try this:

#include "ti83plus.inc"
    .org userMem-2
    .db $BB, $6D
    b_call(_ClrLCDFull)        ; Clears the LCD and marks it as clean
    ld hl, 0
    ld (penCol), hl            ; Moves the cursor to the top left of the screen
    ld hl, numbers
    b_call(_PutS)              ; Prints the numbers
    b_call(_NewLine)           ; Prints a newline character

    .db "123456", 0

Source: http://tutorials.eeems.ca/ASMin28Days/lesson/day02.html

I've had plenty of strange issues with the simplest of ASM programs caused by not clearing the LCD before execution. This is extremely simple, but it worked for me on SourceCoder and Wabbitemu.

Updated incorrect capital letter
Given you're emulating an 84+SE, I suspect MathPrint is to blame. Try disabling MathPrint in the MODE menu then running the program. (You can also disable it by twiddling one of the flags, though that may not be a very nice UX if you quietly disable it.)

calclover2514 wrote:
(although SourceCoder is kind of broken right now)
I've heard nothing of the sort. Can you elaborate?
Thanks Tari and calclover2514 for your responses. I disabled MathPrint and my code worked. It displayed the numbers 123456. When I try the above code I get an error on line ld (PenCol), hl . I’ll have to look thru the ti83 include file and see if I can find PenCol or figure out why it’s an error.

PS. I needed to change PenCol to penCol. It still only displayed the 1, but when I disabled MathPrint it worked. So MathPrint is the problem.

How would I disable MathPrint so I can put it in the code and not have to disable it each time. There’s too much to look at in the include file and I don’t know what I’m looking for anyways.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum