Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
A few days ago, I was writing a quadratic solver on the calculator in BASIC. I ran it from Cesium and the first thing that happened was that the first variable prompt displayed several lines down from the top where it should have been with a small, solid black box in front of it. The box moved with the caret if I tried to type anything. Each time I hit enter, the next prompt displayed where the previous one had been. When the program exited, the screen went black. After a second, blue pixels appeared at random on the right half of the screen. A few seconds later, it blacked out again. I tried turning it on and off, but to no avail. Finally, I reset the calculator and got the RAM Cleared message.

I have crashed my calculator several times by running ICE programs that I've made and have had several odd side effects from that. So, I reset my memory and put everything back on the calculator. I made a test program with a input command, and the prompt appeared on the bottom half of the screen again with the black box. I hit on, opted to quit, and the screen blacked out again. Same odd graphic display, same forced reset.

Next, I resent the OS (5.3.1) and reinstalled Cesium. I made another test program, experienced the same misplaced prompt, and it crashed/froze again.

Since then I have not put anything on the calculator except for BASIC programs. So far, nothing has gone wrong, but I am worried about what has happened.

If anyone could tell me what has happened, and whether or not it is fixable, I would very much appreciate it!

EDIT: After running Self-Test, problem was resolved.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement