Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
I looked at a lot of other jsTIfied and iPad discussions for the past couple of days, but I havenít found anything that helps. I put jsTIfied on my PC a few years ago and as far as I remember everything worked OK. The calculator that shows is the TI 84 Plus Silver Edition. The calculator works just like the real one, so everything is setup OK. I can write a basic program and transfer it to the calculator and run the program. The problem is it wont do anything with an assembler program when I select z80 or ez80 and press the Check button. The Check button changes color for a second, but nothing happens. If I select ez80 C and press Check, it runs and gives me errors which I expect because itís not an ez80 C program. I put jsTIfied on my iPad Air (iOS 12.0.1) and the same assembler program compiles OK with no errors when I select z80 and press Check. The problem with my iPad Air is the calculator part wonít work. On my PC I ran the option to create the jpg image and sent it to the iPad. I sent it one way using Dropbox and another by emailing it to my photos. If I load the ROM from Dropbox, the TI 84 Plus Silver Edition skin shows, but thereís a large black square covering the calculator screen and I canít get the calculator to work. If I load the Rom from photos, a TI 82 skin shows and everything looks OK, but the calculator wonít work. The screen is a white square and if I tap on it, it eventually changes to a normal looking bluish green screen, but it still doesnít work. As I said above, I looked thru a bunch of discussions for hints, but didnít find anything.
I think you're going about loading the ROM incorrectly. If you have a recent OS (iOS 11 and above I think) you can choose to save the ROM image (NOT the jpeg, I think the file extension is .rom) from your Dropbox to your local files. Save it to your iPhone or to your iCloud Drive.
Now go back to jsTIfied and choose the option to upload a ROM image, go to 'browse', then navigate to the place where you saved the ROM image and select it. Wait a few seconds for everything to go through then turn on the emulated calculator. It should be working now, at least it worked for my iPhone SE.
Now you can save the website link as an app to your home screen! Bam, a free (web-based) TI 84 app! Very Happy
Thanks TheLastMillennial, that worked. I sent my .rom file to Dropbox and loaded it from there and the calculator now works as a TI 84 Plus Silver Edition. Now I just need to figure out why I canít compile a z80 program on my PC. The first time I try a z80 program after logging in, a message flashes on the screen for a fraction of a second. Too fast to read. So I took my iPad and recorded the screen as I compiled. This is the message that flashes. ďWaiting for Network. Operation is taking longer than expected, please be patient or check network connectivityĒ. But I donít understand why that happens on a z80 ASM or a ez80 ASM but not on a ez80 C ASM.
My next problem with jsTIfied on the ipad is keying in a program. When I press a key on the keyboard, thereís a key on the calculator that gets pressed. Is there something to set so that what I key goes into the program area and not to the calculator.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement