Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
PT_ wrote:
That is because you can only take the factorial of integers, so you will only see some points (if you can see them with the current window) and not a line.

oh, he is trying to graph "X!", I interpreted it as he was trying to graph "X". As stated above, factorial function is only defined for integers (Although the calculator will allow you to calculate it for half-integers, like 2.5 as well, because those have nice-ish solutions). If you would like a more continuous graph, you will have to graph the analytic continuation of the factorial function, which is commonly known as the Gamma function. Here is what it looks like

However, this isn't quite as easy as dumping an equation in the Y1 slot and graphing it, because you need calculus to work out the values, which the calculator can't do. I remember a while back, I had "graphed", by creating a program that approximates the values numerically at a bunch of points and then graphs all those points, but I can't find it.

EDIT:
I didn't find it, but I did find some old code, which uses Lanczos approximation, which I modified

Code:
A→Z
If 0>real(A
1-Z→Z
e^((Z-.5)ln(Z+8.5)-Z-8.5+ln(√(2π)(1+sum({5716.4001882743,-14815.304267684,14291.492776575,-6348.1602176415,1301.6082860583,-108.17670535144,2.6056965056118,-0.0074234525,5.384136 10^-8,-4.02353 10^-9}/(Z-1+cumSum(binomcdf(9,0
If 0>real(A
2πi/Ans/(2isin(πA
Pause Ans

That should approximate the gamma function at A, and print the result, but I edited this in notepad without testing anything, so it may not be quite right.
IDK if this was already mentioned but...
In TI84CE, version 5.3.0.0037, when you are in the program editor and hold down on the down button when in ALPHA lock, occasionally it will stop and fill the line with random letters.

Is there a fix or is this just a bug?
Piecewize may crash the TI-84+CE os 5.3 on occasion, possibly with ICE installed.
Can't replicate in CEmu, but can on the physical calc.
Select classic instead of mathprint. Select piecewize from the [math] menu. This should crash.
This might just be my calc though Razz

EDIT: Piecewise doesn't work when the calc has just been reset and piecewise has not been selected and
stat wizards are off. select piecewise and your calc will crash, showing a full-screen blue screen that does not go away until a manual reset. If on CEmu, you will have to reload the rom; resetting does not work. If on the actual calc, just press the reset hole.
Yeah, it might be just you. I just RAM cleared (intentionally, via mem menu), then did the above steps, on the homescreen and graphscreen. Nothing happened, and I have ICE installed.
beckadamtheinventor wrote:
Piecewize may crash the TI-84+CE os 5.3 on occasion, possibly with ICE installed.
Can't replicate in CEmu, but can on the physical calc.
Select classic instead of mathprint. Select piecewize from the [math] menu. This should crash.
This might just be my calc though Razz


What did you do with piecewise? What expression did you put in?


SM84CE wrote:
Yeah, it might be just you. I just RAM cleared (intentionally, via mem menu), then did the above steps, on the homescreen and graphscreen. Nothing happened, and I have ICE installed.


Try redoing the steps, but before, run ICE once. ICE gets "installed" when you run it.


EDIT: I wasn't able to replicate. With/without ICE installed.
I found a different bug. Push [Math][left] and select randNorm( while on the home screen. A menu should pop up in which you type in the mean, standard deviation, and the number of repetitions. Put anything in these boxes and scroll down to paste. If you press left with the cursor on paste, you will see whatever you typed for the number of repetitions reappear.
MMMMMMMMMMMMM wrote:
I found a different bug. Push [Math][left] and select randNorm( while on the home screen. A menu should pop up in which you type in the mean, standard deviation, and the number of repetitions. Put anything in these boxes and scroll down to paste. If you press left with the cursor on paste, you will see whatever you typed for the number of repetitions reappear.

haha this is a nice one! This also works in the randBin( menu
Just grabbed a screenshot of that glitch.
Found a bug on the 84+CE, 5.3.0.0037
From either the homescreen or from within the program editor, hit [VARS], [5], [Right], [Right], and you should be highlighting "RegEQ". Hit [Enter] as if to paste it in. The menu exits but nothing pastes.
RegEQ is not a normal token, that menu item is used to paste the last regression equation, which by default is empty.
I think this is a bug, on OS 5.3, when a physical keyboard is connected, the program editor F5 menu can be accessed by pressing F5 on the keyboard (EDIT: while on the homescreen). In addition, selecting one of the entries adds that token to the homescreen where it can be executed (albeit as an syntax error). It pastes in tokens such as "Execute Program", "Copy Line" and "Insert Comment".
LAX18 wrote:
I think this is a bug, on OS 5.3, when a physical keyboard is connected, the program editor F5 menu can be accessed by pressing F5 on the keyboard.

That sounds like a feature?

LAX18 wrote:
IIn addition, selecting one of the entries adds that token to the homescreen where it can be executed (albeit as an syntax error).

Which token exactly?
Adriweb wrote:
LAX18 wrote:
I think this is a bug, on OS 5.3, when a physical keyboard is connected, the program editor F5 menu can be accessed by pressing F5 on the keyboard.

That sounds like a feature?

LAX18 wrote:
IIn addition, selecting one of the entries adds that token to the homescreen where it can be executed (albeit as an syntax error).

Which token exactly?


I've seen this actually.



After further investigation (I put as many appvars into the RAM as possible):

It got stuck here (presumably at the end of User RAM):

Dissasembly (It would not step the clock at all, probably the preceeding HALT instruction):

It was off, but the on button does nothing:

Do [on]+[2nd]+[del]+[reset] it will go back to where it was at before turning off, and actually won't reset until it is reset again

Ik I'm probably looking into this waaay more than I should Razz

(Also: This is the piecewise bug I've noticed before)

Code:
DelVar L₁:1→dim(L₁
"seq(L₁(1),F,1,1→L₁
L₁

not sure if this counts as a bug, but it's been driving me crazy.
https://imgur.com/a/nVB6QnC
Thanks all for your responses. i was having similar questions and your answers were helpful to me.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 11 of 11
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement