Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
Hey guys, I got a document scanner from a free pile and it still works! Except, there's a black bar going down each and every page. I have a feeling it's the ribbon cable but would like a second opinion before take this apart. I tried wiping down that side of the scanner and it had no affect.



Here I scanned a recipe card (8.5x11) and there's some of the information making it's way through but if I scan a text document, the bar is a more solid black. The second image here is what the scan looked like after cleaning, then it went right back to a black bar for the next scan (the images above)

Almost definitely. The symptom where the blue channel came back momentarily seals the deal for me, considering I expect the ribbon cable to carry several parallel sets of R, G, B channels. (Thanks to jonbush for inspiring me to elaborate on my process of deduction slightly.)
KermMartian wrote:
Almost definitely.


Yep. I was just looking through some data sheets for linear CCD sensors, and it seems that the outputs are often segmented into several regions to increase the transmission speed. If one (or more) of the wires in the ribbon cable is broken, this is what I would expect to see.
Sweet, thanks guys. I'll take it apart this weekend and see what I'm up against.
Alex wrote:
Sweet, thanks guys. I'll take it apart this weekend and see what I'm up against.
How did it go? What did you discover?
I discovered it's a pain in the butt to open. Lack of documentation and tutorials. I suspect once I got past the 4 screws holding the shell on the rear of the device, I suspect there are a series of clips I need to work around. That's where the documentation would help.

I mean, it was free so I could break it.

I did manage to track the ribbon cable and poked at the mother board, removed the screws for that and examined it. Nothing seemed bad there. So, the issue definitely lies deeper in the unit. Plot twist though, it's a duplex scanner so I just set it up for single-plex scanning and the scans come out fine.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement